UebiMiau stopped working after Apache reinstall

Discussion in 'Installation/Configuration' started by shajazzi, Feb 17, 2006.

  1. shajazzi

    shajazzi New Member

    I set up suse 9.3 and ispconfig. Everything was working fine untill my server name kept changing to www from server 1.
    By mistake i change something in YAST/HTTP Server and lost Apache settings and couldn`t get it running again.(This area in the server seems to be very vunerable next time I`ll sit on my hands.)
    I removed apache completely then reinstalled it again.Then i found Ispconfig not working properly so instead of fixing it i reinstalled.
    Now all is OK apart from UebiMiau webmail.
    I can send to external email address but cannot receive from internal or external mail
    addresses

    This is in mail error log:

    Feb 17 18:09:08 server1 postfix/smtpd[9215]: connect from localhost[127.0.0.1]
    Feb 17 18:09:08 server1 postfix/smtpd[9215]: BA40A3E127: client=localhost[127.0.0.1]
    Feb 17 18:09:08 server1 postfix/cleanup[9218]: BA40A3E127: message-id=<20060217180908.BA40A3E127@server1.example.com>
    Feb 17 18:09:08 server1 postfix/qmgr[8574]: BA40A3E127: from=<admin@englandshirt.com>, size=733, nrcpt=1 (queue active)
    Feb 17 18:09:08 server1 postfix/smtpd[9215]: disconnect from localhost[127.0.0.1]
    Feb 17 18:09:08 server1 pop3d: Connection, ip=[::ffff:127.0.0.1]
    Feb 17 18:09:08 server1 pop3d: LOGIN, user=web1_steve, ip=[::ffff:127.0.0.1]
    Feb 17 18:09:09 server1 pop3d: LOGOUT, user=web1_steve, ip=[::ffff:127.0.0.1], top=0, retr=0, time=1
    Feb 17 18:09:09 server1 postfix/smtp[9220]: BA40A3E127: to=<web4_dave@server1.example.com>, orig_to=<admin@chace-catering.co.uk>, relay=none, delay=1, status=bounced (Host or domain name not found. Name service error for name=server1.example.com type=AAAA: Host not found)
    Feb 17 18:09:09 server1 postfix/cleanup[9218]: 1E6C35416D: message-id=<20060217180909.1E6C35416D@server1.example.com>
    Feb 17 18:09:09 server1 postfix/qmgr[8574]: 1E6C35416D: from=<>, size=2768, nrcpt=1 (queue active)
    Feb 17 18:09:09 server1 postfix/qmgr[8574]: BA40A3E127: removed
    Feb 17 18:09:09 server1 postfix/smtp[9220]: 1E6C35416D: to=<web1_steve@server1.example.com>, orig_to=<admin@englandshirt.com>, relay=none, delay=0, status=bounced (Host or domain name not found. Name service error for name=server1.example.com type=AAAA: Host not found)
    Feb 17 18:09:09 server1 postfix/qmgr[8574]: 1E6C35416D: removed
    Feb 17 18:15:06 server1 pop3d: Connection, ip=[::ffff:127.0.0.1]
    Feb 17 18:15:06 server1 pop3d: LOGIN, user=web4_dave, ip=[::ffff:127.0.0.1]
    Feb 17 18:15:06 server1 pop3d: LOGOUT, user=web4_dave, ip=[::ffff:127.0.0.1], top=0, retr=0, time=0
    Feb 17 18:19:11 server1 pop3d: Connection, ip=[::ffff:127.0.0.1]
    Feb 17 18:19:11 server1 pop3d: LOGIN, user=web1_steve, ip=[::ffff:127.0.0.1]
    Feb 17 18:19:11 server1 pop3d: LOGOUT, user=web1_steve, ip=[::ffff:127.0.0.1], top=0, retr=0, time=0
    Feb 17 18:25:06 server1 pop3d: Connection, ip=[::ffff:127.0.0.1]
    Feb 17 18:25:06 server1 pop3d: LOGIN, user=web4_dave, ip=[::ffff:127.0.0.1]
    Feb 17 18:25:06 server1 pop3d: LOGOUT, user=web4_dave, ip=[::ffff:127.0.0.1], top=0, retr=0, time=0
    Feb 17 18:29:11 server1 pop3d: Connection, ip=[::ffff:127.0.0.1]
    Feb 17 18:29:11 server1 pop3d: LOGIN, user=web1_steve, ip=[::ffff:127.0.0.1]
    Feb 17 18:29:11 server1 pop3d: LOGOUT, user=web1_steve, ip=[::ffff:127.0.0.1], top=0, retr=0, time=0

    In dnsreport I get this:

    WARNING: One or more of your mailservers is claiming to be a host other than what it really is (the SMTP greeting should be a 3-digit code, followed by a space or a dash, then the host name). This probably won't cause any harm, but is a technical violation of RFC821 4.3 (and RFC2821 4.3.1). Note that the hostname given in the SMTP greeting should have an A record pointing back to the same server.

    mail.englandshirt.com claims to be non-existent host server1.example.com:
    220 server1.example.com ESMTP Postfix

    shajazzi:confused:
     
  2. till

    till Super Moderator

    You have to change the hostname of your server in ISPConfig under management > server > settings and in /etc/hostname too.
     
  3. falko

    falko Super Moderator

    In the SuSE 9.3 tutorial ( http://www.howtoforge.com/perfect_setup_suse_9.3 ), you should have replaced server1.example.com with mail.englandshirt.com, for example on page 4:

    Code:
    echo mail.englandshirt.com > /etc/hostname
    /bin/hostname -F /etc/hostname
    and page 5:

    Code:
    postconf -e 'mydomain = englandshirt.com'
    postconf -e 'myhostname = mail.$mydomain'
    But you can still do this now (restart Postfix afterwards). :)
     
  4. shajazzi

    shajazzi New Member

    Thanks till and falko,
    I looked at /etc/hostname and i saw it was listed with server1.example.com. I left that and then went to ISPConfig under management > server > settings and did the following


    Servername example.com
    Hostname server 1

    Everything seems to work OK .
    I don`t know if this is right but it works.
    Thanks Falko, I had already done this before I read your post.
    If I get any more problems I shall use your suggestion.


    shajazzi
     
  5. till

    till Super Moderator

    Please change tho hostname in /etc/hostname and postfix too with the commands that suggested from the howto.

    Otherwise you may encounter problems with other mailservsers that reject your emails because you use an not existing hostname.
     
  6. shajazzi

    shajazzi New Member

    Thanks till,
    That works fine apart from FTP server is now offline. When I restart proftpd I get the following errors:


    Shutting down ProFTPD Server: done
    Starting ProFTPD Server: - getaddrinfo 'mail' error: Name or service not known
    - warning: unable to determine IP address of 'mail'
    - getaddrinfo 'mail' error: Name or service not known
    - warning: unable to determine IP address of 'mail'
    - getaddrinfo 'mail' error: Name or service not known
    - warning: unable to determine IP address of 'mail'
    done
    mail:~ # - getaddrinfo 'mail' error: Name or service not known
    - warning: unable to determine IP address of 'mail'
    - getaddrinfo 'mail' error: Name or service not known
    - warning: unable to determine IP address of 'mail'

    shajazzi
     
  7. shajazzi

    shajazzi New Member

    Sorry till,
    In ispconfig i had the settings wrong,everything is now OK

    shajazzi:D :D :D
     

Share This Page