1. I posted in this section because my first question is regarding UebiMiau on ISPConfig. I am running the Perfect OpenSUSE 10.2 Setup.

    When attempting to send email outside my domain from UebiMiau I receive the error:
    I would probably be more freaked out about this, but when I use a mail client (thunderbird, outlook, etc) I have absolutely no problem sending email. Except to Hotmail and Yahoo., which leads into my next question.

    I am fairly certain that I'm sending out to Yahoo, but it is using the greylisting method and forcing a delay. Hotmail on the other hand does not seem to be receiving my messages at all. My log reports:
    But no one ever receives the messages. And my spf records don't seem to functional on any of my domains. You can use www.frankentech.org to check spf on. I also read that I may need to email webmaster at hotmail to get my domains allowed. Is this true? Would it be the same for yahoo?

    The record reads:
    I appreciate your help with this.
  2. edge

    edge Active Member Moderator

    You do not have a SPF record for frankentech.org
    (have a look here)
    Thats a yes for hotmail, and a yes for yahoo.

    Here is a small quote from Hotmail that I got some time ago:
    So.. Hotmail rates your mail by SmartScreen’s filters AND reputation of the sender

    Some more from the Hotmail email:
    So.. Hotmail needs to add domains to the SenderID program.

    Best is to contact hotmail, and ask if they can add your domain(s).
    Before you do this, MAKE SURE, that all is working the way it should! (DNS, MX, SPF and reverse DNS)
  3. edge

    edge Active Member Moderator

    Did you enable "My outgoing server (SMTP) requires authentication" in your email client?
  4. No problem with email clients. UebiMiau is the only real issue if emailing hotmail and yahoo pans out. I always get the mentioned error message when I try to email from UebiMiau which I installed with ISPConfig.

    Now if there is a setting in UebiMiau that sets it to server authentication then I have completely overlooked it.

    I have adjusted the spf record some, and finally have it working properly. This did not fix UebiMiau.

    Thanks for the help.
    Last edited: Apr 2, 2007
  5. till

    till Super Moderator Staff Member ISPConfig Developer

    This is not nescessary for uebimiau, as ist sends from the localhost IP which is always allowed to send mail.

    Have you entered a correct sender address in the uebimiau options?
  6. falko

    falko Super Moderator ISPConfig Developer

    Yes, that's correct.
  7. till

    till Super Moderator Staff Member ISPConfig Developer

    Please post an excerpt of ypur mail logfile.
  8. OK, I've been dealing with so many other things that I couldn't get back to this until now.

    So, the attached is an excerpt from the log file showing the exact instance that I logged into web mail and attempted to send a message to an outside location.

    I installed Roundcube to be sure it wasn't an issue with UebiMiau and it is not. Roundcube has the exact same problem. They can send messages internally with no problem, but if I try to send outside I get the attached error. I took a look in the mail.info log to see what it had to say and I think I may have learned something about the problem, but still do not know how to fix it.

    When you access using a client you are using pop3, but when you access through web mail you are on imapd. I have no problems with sending or receiving from pop3, and just sending with imapd on the web mail. So this issue appears to be specific to imapd.
    View attachment mail.txt
  9. falko

    falko Super Moderator ISPConfig Developer

    What's the value of mynetworks in /etc/postfix/main.cf? Is frankentech.org listed in /etc/postfix/local-host-names?
  10. I think you are on to something. I just have to figure out how to enter it now. The mynetworks is I just realized that when I moved the server to a new facility is when it stopped working on webmail. The new addresses are 199.X.X.248-255 and the server is on 250, which I think means that I need to enter 199.X.X.0/29.

    The local host file is correct.
  11. falko

    falko Super Moderator ISPConfig Developer

    That's the problem. With this setting, localhost cannot send without authentication.
    Please run
    postconf -e 'mynetworks ='
    and restart Postfix.

Share This Page