Uebimiau And Roundcube Email: User Prefix problem

Discussion in 'General' started by Jaac, Nov 25, 2007.

  1. Jaac

    Jaac New Member

    Hi guys,

    Been reading a lot of threads and guides on this site (awesome site) but still i havent been sure on what to do, to fix the user prefix for email login.

    Ive added both Uebimiau and Roundcube using the guides on site.

    Eubimaiu runs on: https://www.example.ltd:81/webmail
    Roundcube on: http://webmail.example.ltd/

    The users emailadres is: [email protected],
    but his login is: [email protected]

    Now one of my questions is, is it safe to remove the;
    ISPConfig > Management > System Config > ISP Manager > User Prefix?

    Its is setup as: web[WEBID]_
    So removing it would end up with a username only!?

    But would it mess up the internal system? Or would it need a complete re-creation of the users and sites, for ispconfig to create emails and webs without the prefix.

    Or is there another way to come by that?

    Would it also be possible to get root, and linux users emails linked to the same webmail (as its the same domain)?

    Thanks in advance for your help.
    Greetz, Jaac

    {using Ubuntu 7.10; Perfect Install + ISPconfig}
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    It is always safe to remove the user prefix. But it will limit your server as every username must be unique for the whole server and you will get complaints from your customers if the add a user "info" and get the message that the user already exists because a other customer created thie user already.

    By the way, uebimiau uses always the email address as login, yo it doe not make a difference for this webmail application if you use a user prefix or not.
  3. Hans

    Hans Moderator ISPConfig Developer

    If you use my RoundCube howto it is possible to login with the loginname and password AND e-mailadress and password as well.
    This is also possible with the RoundCUbe package for ISPConfig.

    For more information about my howto, have a look here:
  4. digerati

    digerati New Member

    I have been working on this all day and it has not worked yet.

    I currently have a blank white page when I should see a login.

    this is so aggrevating
  5. Hans

    Hans Moderator ISPConfig Developer

    Maybe it's because of the .htaccess files.
    RoundCube makes use of .htaccess files, so you must give permission to use this. Did you put the following lines into your apache directives field of your web?:

    <Directory "/var/www/web1/web">
    Options FollowSymLinks
    AllowOverride All

    Where web1 is your own webnumber of course.

    Please also have a look in the logs directory within your RoundCube directory.
    Do you see any related errors there?

Share This Page