Ubuntu Server on RAID 1 boot with RAID 1 data array.

Discussion in 'Installation/Configuration' started by MattJo., May 29, 2010.

  1. MattJo.

    MattJo. New Member

    Hello,


    I would like to install Ubuntu Lucid Perfect Server with ISPConfig 3 onto a RAID 1 boot array and store the data on a secondary array also in RAID 1.

    I have seen instructions on how to install the system onto a RAID 1, but not in the about config and also they don't say anything about whether I need to configure the onboard RAID controller (Intel Matrix).

    I had originally tried to install onto an array configured with the onboard RAID, but the installation failed.

    Any help would be much appreciated

    For reference the board I am using in this build is a Supermicro X7SBL-LN2.

    thanks,

    Matt
     
  2. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

  3. MattJo.

    MattJo. New Member

    Install ISPconfig 3 on data array

    Falko,

    I was able to get server up and running with the RAID boot array--I actually was able to install and configure from scratch using the instructions on the main canonical site--initially had some grub errors, but apparently (at least with my system) this is/was solved by disabling the floppy drive/drive A/anything remotely related to floppy drives.

    Anyway, I don't have a clue how to proceed with installing ISPConfig and its parts onto the data array. Or rather I would like to ensure that the users data is stored on the data array (ie FTP files, e-mails, web pages, databases, etc.).

    Is there a simple command I can input while following your instructions for this or is this a larger endeavor than it would appear?

    thanks,

    Matt
     
  4. MattJo.

    MattJo. New Member

    RAID running/Directories

    OK, apologies for the overlap--I know this isn't the ISPconfig forum, but since this started here.... Also for my complete ignorance.

    So, I have the RAID setup on both the boot disk and the data disk with Lucid installed. However, I think the install defaulted to using dmraid instead of mdadm. I know that mdadm by all accounts is preferable to dmraid--how can I tell which is used? If it is dmraid can I use your guide to change over to mdadm--or am I a complete idiot and misconstruing everything?

    Second question. When I installed, I configured the DATA array to have the /home directory essentially out of--my ignorant--attempt to make sure that the FTP directories, e-mail database, etc were created on the larger data drive when I installed ISPconfig. So, assuming this was completely noobed-up what should I do to ensure that the databases, FTP, emal, etc.,. end up on the larger data array? Do I have to install and then move particular directories? What/how settings do I have to change assuming this is the case?

    thanks much for your help.

    Matt
     
  5. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    Can you post the outputs of
    Code:
    cat /proc/mdstat
    and
    Code:
    mount
    ? What's in /etc/fstab?
     
  6. MattJo.

    MattJo. New Member

    Personalities : [linear] [multipath] [raid0] [raid1] [raid6] [raid5] [raid4] [raid10]
    md2 : active raid1 sdd1[1] sdc1[0]
    1953513408 blocks [2/2] [UU]

    md0 : active raid1 sdb1[1] sda1[0]
    7811008 blocks [2/2] [UU]

    md1 : active raid1 sdb2[1] sda2[0]
    23453632 blocks [2/2] [UU]

    unused devices: <none>


    /dev/md1 on / type ext4 (rw,errors=remount-ro)
    proc on /proc type proc (rw,noexec,nosuid,nodev)
    none on /sys type sysfs (rw,noexec,nosuid,nodev)
    none on /sys/fs/fuse/connections type fusectl (rw)
    none on /sys/kernel/debug type debugfs (rw)
    none on /sys/kernel/security type securityfs (rw)
    none on /dev type devtmpfs (rw,mode=0755)
    none on /dev/pts type devpts (rw,noexec,nosuid,gid=5,mode=0620)
    none on /dev/shm type tmpfs (rw,nosuid,nodev)
    none on /var/run type tmpfs (rw,nosuid,mode=0755)
    none on /var/lock type tmpfs (rw,noexec,nosuid,nodev)
    none on /lib/init/rw type tmpfs (rw,nosuid,mode=0755)
    none on /var/lib/ureadahead/debugfs type debugfs (rw,relatime)
    /dev/md2 on /home type ext4 (rw)
    binfmt_misc on /proc/sys/fs/binfmt_misc type binfmt_misc (rw,noexec,nosuid,nodev)
    gvfs-fuse-daemon on /home/*______*/.gvfs type fuse.gvfs-fuse-daemon (rw,nosuid,nodev,user=*______*)

    # /etc/fstab: static file system information.
    #
    # Use 'blkid -o value -s UUID' to print the universally unique identifier
    # for a device; this may be used with UUID= as a more robust way to name
    # devices that works even if disks are added and removed. See fstab(5).
    #
    # <file system> <mount point> <type> <options> <dump> <pass>
    proc /proc proc nodev,noexec,nosuid 0 0
    # / was on /dev/md1 during installation
    UUID=300c9de9-ed89-4206-b6ab-999x99x99x99 / ext4 errors=remount-ro 0 1
    # /home was on /dev/md2 during installation
    UUID=238ff430-b67f-48e9-9ebf-999x99x99x99 /home ext4 defaults 0 2
    # swap was on /dev/md0 during installation
    UUID=25d7a156-a5ff-4304-a04e-999x99x99x99 none swap sw 0 0
     
  7. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    Looks good. You're using mdadm. :)
     

Share This Page