Ubuntu Server 7.10 - ISPConfig install fails on PHP

Discussion in 'Installation/Configuration' started by olavxxx, Feb 4, 2008.

  1. olavxxx

    olavxxx New Member

    yes, I have tried:
    installing zlib, I also tried
    rm -f /bin/sh
    ln -s /bin/bash /bin/sh

    Hope someone has some tips for me.. I followed the install from the perfect server guide, here on howtoforge.

    Ps. I took the 64bit Ubuntu server, not the 32.. Dont know if this matters?
    I seem to remember that there was some error when I installed the PHP, and had to cut out something from the syntax.-
     
  2. olavxxx

    olavxxx New Member

    Ok, I'm currently trying to redo all steps on the server.
    Still get this error on the PHP, which I think may be what crashes the ISPconfig?

    ---

    EDIT:
    I may have solved the issue..

    Seems I did nothing wrong, but on 64 bit, you have to run this command too:

    sudo apt-get install libssl-dev

    Im further down on the installation path now and I recreated all steps and everything was correctly installed.
    Seems also the failed php module as I refer to above, is also installed in the common package, so I dont have to think more about that one.
     
    Last edited: Feb 5, 2008
  3. olavxxx

    olavxxx New Member

    New problem :S

     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Please make sure that you install and use the zlib package that comes with ubuntu and not a zlib that yoiu compiled manually. Did you follow exactly the ISPConfig installation Guide for Ubuntu 7.10?
     
  5. olavxxx

    olavxxx New Member

    yes, I have even done it again..
    However, what I THINK is the problem now, is that I am running 64bit.

    I googled some today and some guy said something about compiling PHP on 64bit, that you had to edit a "makefile". But I dont know where this makefile is? Tried looking for it.
     
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    ISPConfig works and compiles perfectly on 64Bit Systems and PHP has no problems with 64Bit too.

    The problem is that you installed / compiles a version of the zlib library manually, which is not from Ubuntu and is compiled with the wrong parameters. The default ubuntu libraries are never installed in /usr/local/lib/

    What you might try is:

    mv /usr/local/lib/libz.a /usr/local/lib/libz.a.old

    and then unpack ISPConfig again and run the setup script.
     
  7. olavxxx

    olavxxx New Member

    Thank you! You where correct on the zlib issue!

    Now it installed properly, connected to the db, etc. but I have done something wrong when making the ssl certificate, so I cant acecss the admin :S

    Guess I'll have to rtfm, lol.. I'll try recreating it later today, or maybe reinstall and use http instead of https... hmm.. anyways, thx :)
     
  8. falko

    falko Super Moderator ISPConfig Developer

  9. olavxxx

    olavxxx New Member

    I'm in!!

    Had to do:
     
  10. Millusdk

    Millusdk New Member

    I get the same PHP error, even though i have the zlib package installed. However I am not using Ubuntu server, but Xubuntu instead. I hope you can help.
     
  11. olavxxx

    olavxxx New Member

    Hi, try this:
    sudo apt-get install libssl-dev

    Also, double check that you have all your configurations set up as in the perfect server guide.

    You also have to fix the default shell, etc. as per. the guide.
    If it still does not work, I would try to wget the tar file again and unpack it with tar -zxvf

    I had no problems installing it after I moved the zlib, but before I installed the zlib, I had problems.

    Only thing I can think might have been the problem, is that I did not have the libssl-dev, as all my configurations where a-ok.
     
  12. Millusdk

    Millusdk New Member

    I have now followed the entire perfect server setup, and i have libssl-dev installed, however it does not help :confused: i still get the same error message saying that the version of PHP does not work with my system :( what can i do to make it work
     
  13. falko

    falko Super Moderator ISPConfig Developer

    What's the exact error message you're getting now?
    Are you sure you followed the Perfect Setup as close as possible?
     
  14. Private Detective

    Private Detective New Member

    I've followed perfect setup, but have got the same error...

    Tried: installing zlib

    then tried to install zlib using apt-get install zlib-bin

    then tried "mv <...> libz.a" command from prev. page

    But error still persists. Could you help me?
     
  15. falko

    falko Super Moderator ISPConfig Developer

    What's the output of
    Code:
    df -h
    ?
     
  16. Private Detective

    Private Detective New Member

    [email protected]:~# df -h
    Filesystem Size Used Avail Use% Mounted on
    /dev/sda1 37G 1,3G 34G 4% /
    varrun 252M 84K 252M 1% /var/run
    varlock 252M 0 252M 0% /var/lock
    udev 252M 36K 252M 1% /dev
    devshm 252M 0 252M 0% /dev/shm
     
  17. Private Detective

    Private Detective New Member

    Apache&php5 for ISPConfig installation should start immediately after "./setup" command?

    EDITED: no... :)
     
    Last edited: Feb 18, 2008
  18. falko

    falko Super Moderator ISPConfig Developer

    Which distribution are you using? What's the output of
    Code:
    uname -a
    ?
     

Share This Page