Ubuntu Samba Standalone Server - access problems

Discussion in 'HOWTO-Related Questions' started by windy, Jan 23, 2008.

  1. windy

    windy New Member

    [SOLVED] Ubuntu Samba Standalone Server - access problems

    Thanks for the HowTo - However I have been struggling for hours with what I think is a users/groups problem.

    Here is my smb.conf - some sections omitted:

    workgroup = VIVACE
    server string = %h server (Samba, Ubuntu)
    obey pam restrictions = Yes
    passdb backend = tdbsam
    passwd program = /usr/bin/passwd %u
    passwd chat = *Enter\snew\sUNIX\spassword:* %n\n *Retype\snew\sUNIX\spassword:* %n\n *passwd:*password\supdated\ssuccessfully* .
    security = user
    ; username map = /etc/samba/smbusers
    syslog = 0
    log file = /var/log/samba/log.%m
    max log size = 1000
    dns proxy = No
    panic action = /usr/share/samba/panic-action %d
    invalid users = root

    comment = Home Directories
    path = /var/samba/shares/homes/%u
    valid users = %S
    read only = No
    create mask = 0700
    directory mask = 0700
    browseable = No

    comment = All Users
    path = /home/shares/allusers
    valid users = nigel
    ; force group = users
    create mask = 0660
    directory mask = 0771
    writable = yes

    I can access home directory OK using user nigel.

    I am having problems with allusers. I can access with smb.conf set as above with valid user = nigel, but if I enable force group = users I cannot access the share. Also if I set valid users = @users I cannot access the share either.

    getent group | grep users returns

    [email protected]:~# getent group | grep users
    [email protected]:~#

    confirming nigel is in the group users

    permissions on the /home/shares/allusers were set as per the HowTo and users added in the same way too.

    In the interest of a server remaining in a nice warm office and not out in the rain, I would be really grateful for some assistance.

    Last edited: Jan 27, 2008
  2. falko

    falko Super Moderator ISPConfig Developer

    Are there any errors in the logs?
  3. windy

    windy New Member

    [SOLVED] Re: Samba access problems with group users

    Following some help via Ubuntu server forum - I tried something different - I set up another group "samba", added the users to it and accessed the share OK.

    Then tried the force group and couldn't access. Then retyped the force group on a new line with "samba" and deleted the old - all OK now.

    Then retried with "users" and all errored again.

    Don't know why, maybe there is something odd about by "users" group; I don't intend to waste any more time trying to get it working with "users".

    So thanks to cdenley @ ubuntuforums for the diligent support.

Share This Page