Ubuntu Perfect Setup and File Permissions

Discussion in 'Installation/Configuration' started by parkerj, Mar 17, 2007.

  1. parkerj

    parkerj Member HowtoForge Supporter

    I used the perfect setup for Ubuntu 6.06. When I upload a .php file, I get a 500 internal server error. Once I change the file persmission then it works. Directories are chmoded to 775 and files are chmoded to 664. Also, I have suPHP enabled, so that every site that is created is automatically configured for the user. Can someone point me in the right direction of what could be wrong? Thanks.
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Which error is logged to the error log of the website as reason for the 500er error?
     
  3. parkerj

    parkerj Member HowtoForge Supporter

    Before I chmoded the web folder to 755, I would get the error below. After chmod there are no errors in the log, but I still get the 500 internal error. I am assuming it is an error because the index.php file in the web folder is chmoded to 664.

     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Please edit your suphp config file (it should be in the directory /etc/suphp or similar) and disable the group writable check. This check is not nescessary in ISPConfig because every website has its own group and the files must be group writable.
     
  5. parkerj

    parkerj Member HowtoForge Supporter

    Would disabling mean making it "false" or by putting a "#" in front of it? Thanks.
     
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    If the value is now true, please change it to false and do not comment out the line.
     
  7. parkerj

    parkerj Member HowtoForge Supporter

    Thank you but all of the values were false and I was till having these issues.
     
  8. falko

    falko Super Moderator ISPConfig Developer

    Please change something for a web site in ISPConfig so that Vhosts_ispconfig.conf gets rewritten.
     

Share This Page