Ubuntu Perfect Server 11.10: after Update Problems with Mail: trivial-rewrite

Discussion in 'Installation/Configuration' started by ahsamuel, Apr 10, 2012.

  1. ahsamuel

    ahsamuel New Member

    had a working Server 10.04LTS w/ ISPConfig 3 (Perfect Server from howtoforge), upgraded today to 11.10, and got problems with the mail:

    I can't use pop3/smtp anymore!

    first, i could solve it with http://www.howtoforge.com/ubuntu-11...-authentication-failed-no-mechanism-available

    but then i get errors like this:
    i have updated to 12.04 in the hope to solve this since i read about problems in 11.10 (downgrade of some packages, i tried without success)...

    dear @falko, i need your help! :confused:



    here are a few config files:
    main.cf
    master.cf
     
  2. Mitzy

    Mitzy New Member

    Just out of curiosity which method did you use to try and solve the 'no mechanism' problem? Did you downgrade sasl or did you do what was suggested in the comments?
     
  3. ahsamuel

    ahsamuel New Member

    i did the change in the config - worked.

    but no luck with the rest :(
     
  4. Mitzy

    Mitzy New Member

    I was in a similar situation, are you in a position to start from scratch?

    Back up all your existing databases and www folders, wipe, do a clean install of 11.10, the config edit as you've mentioned above and you should be good to go.

    Realistically you're looking at abut 6 hours off line depending on how much you need to back up then restore.

    You've probably already read this but might be worth a tweak http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=457864
     
    Last edited: Apr 10, 2012
  5. itanium

    itanium New Member

    Hi,

    Same problem with a new install of ubuntu 12.04. We need to remove chroot from the master.cf config file of postfix and now it work. Now we need to find why...
     

Share This Page