Ubuntu "Perfect Install" - MYSQL Help Needed

Discussion in 'Installation/Configuration' started by thecgmguy, Nov 13, 2006.

  1. thecgmguy

    thecgmguy New Member

    Hello Folks,

    I've been trying to configure Ubuntu Server 6.06 according to the "perfect setup" guide here: http://www.howtoforge.net/perfect_setup_ubuntu_6.06_p4

    I'm running into trouble configuring MYSQL.

    I'm at the portion of the tutorial where I'm trying to specify a password for user root.

    I start by typing this command:
    mysqladmin -u root password yourrootsqlpassword

    That works fine. But when I type the following command:
    mysqladmin -h server1.example.com -u root password yourrootsqlpassword I get an error about my server not being allowed access.

    Has anyone come across this before? Note that the above entry is an example. I've replaced my FQDN and actual password when actually doing this.

  2. Nap

    Nap Member

    Hi thecgmguy,

    I'm no expert here, but I seem to recall having a similar issue while I was installing Debian on my machine. I didn't report it here since it was not the first item on my priority list at the time and was intending to install ISPConfig (which I knew would test it later).

    When I had ISPConfig loaded, I use phpMyAdmin to edit the MySQL privileges table and gave the appropriate rights to the root account. After that, I was able to login using root.

  3. falko

    falko Super Moderator ISPConfig Developer

  4. thecgmguy

    thecgmguy New Member

    Thanks for the prompt replies guys.

    Could I get clarification on what exactly these mysql commands are doing?

  5. entel

    entel New Member


    I get the same error edgy eft


    [email protected]:~# cat /etc/mysql/my.cnf | grep bin
    #bind-address           =
    log_bin                 = /var/log/mysql/mysql-bin.log
    # WARNING: Using expire_logs_days without bin_log crashes the server! See README.Debian!
    max_binlog_size         = 100M
    #binlog_do_db           = include_database_name
    #binlog_ignore_db       = include_database_name
    [email protected]:~# cat /etc/hosts       localhost server1.local.lan
    [email protected]:~# ping server1.local.lan
    PING server1.local.lan ( 56(84) bytes of data.
    64 bytes from server1.local.lan ( icmp_seq=1 ttl=64 time=0.099 ms
    [email protected]:~# mysqladmin -h server1.local.lan -u root password XXXX
    mysqladmin: connect to server at 'server1.local.lan' failed
    error: 'Access denied for user 'root'@'server1.local.lan' (using password: NO)
    [email protected]:~# netstat -tap
    Active Internet connections (servers and established)
    Proto Recv-Q Send-Q Local Address           Foreign Address         State       PID/Program name   
    tcp        0      0 localhost:2464          *:*                     LISTEN     3758/python         
    tcp        0      0 localhost:2208          *:*                     LISTEN     3755/hpiod          
    tcp        0      0 *:imaps                 *:*                     LISTEN     8147/couriertcpd    
    tcp        0      0 *:pop3s                 *:*                     LISTEN     8039/couriertcpd    
    tcp        0      0 *:mysql                 *:*                     LISTEN     22150/mysqld        
    tcp        0      0 localhost:63629         *:*                     LISTEN     4409/wish           
    its running... :(
  6. falko

    falko Super Moderator ISPConfig Developer

  7. falko

    falko Super Moderator ISPConfig Developer

    They are doing nothing wrong, but your hostname is not as it should be, so there's a wrong hostname in the mysql.user table, that's why
    mysqladmin -h server1.example.com ...
    doesn't work.

Share This Page