Ubuntu Linux 10.04-mail issues

Discussion in 'HOWTO-Related Questions' started by Happy, Dec 9, 2011.

  1. Happy

    Happy New Member

    I installed The Perfect Server - Ubuntu Lucid Lynx (Ubuntu 10.04) [ISPConfig 2] some months ago and it has been running fine up until lately. I am only using the following peices pop3/imap using Maildir format and therefore installed Courier-POP3/Courier-IMAP. Alo Mysql,postfix. At any rate here are my issues
    1. Mail seems to be getting delivered most of the time, but all i see copies of it staying on the server after it is delivered.
    2. I have some clients stating that they can't send me email with the following errors
    A. #550 4.4.7 QUEUE,EXPIRED
    B. Router :Failed to connect to SMTP host xxx.net because: The remote server is not a known TCP/IP host.
    I can telnet to port 25. When I check MX Tools it reports no issues with mail server.

    Thanks

    Happy
     
  2. falko

    falko Super Moderator

    Are there any errors in your mail log (in the /var/log/ directory)?

    Where is your server located? In a data center, or at home/in your office?
     
  3. Happy

    Happy New Member

    No errors in logs. However, after talking with users found that some users had the box checked on their email client to leave a copy on server-this would explain seeing emails in users mail box on server. The mail server is located in a office. However, I am still trying to troubleshoot errors reported by users sending emails to our mail server
     
  4. falko

    falko Super Moderator

    Do you have a dynamic IP address? That might be a problem (if the IP changes, this might cause connection problems).

    Your ISP doesn't block port 25, right?
     
  5. Happy

    Happy New Member

    IP address is static and port 25 is allowed. However, I did notice that when I ran MXtool SMTP Diagsthe transactions time was less than desirable as noted below

    OK - x.x.x.x resolves to mail.x.x.x.org
    OK - Reverse DNS matches SMTP Banner
    0 seconds - Good on Connection time
    Not an open relay.
    8.252 seconds - Not good! on Transaction time
     

Share This Page