Ubuntu kernel compilation doesn't reflect changes

Discussion in 'Kernel Questions' started by mjimeno, Jul 19, 2008.

  1. mjimeno

    mjimeno New Member

    Hello all,
    I compiled a new kernel using the following instructions:
    From all the options shown there, I downloaded the source using GIT, then compiled the kernel using this:
    AUTOBUILD=1 NOEXTRAS=1 fakeroot debian/rules binary=generic (they have a typo there BTW)
    It worked fine the first time. It reflected my changes. But then, every time I compile, I don't see the changes reflected. I had to delete all, download a new kernel from GIT, and compile it as if it were the first time and it worked fine again.
    I can say I saw two things:
    1) before deleting all the files and redoing it again, the compilation took much less time every time I did it. I noticed that compared to a first-time compilation, it looks like it were not doing something.
    2) I'm not sure about this, but I saw that the first time it did compile the files, I think because it did a lot of "CC file", which is what takes longer. After the first time, it did only "INSTALL file". Then I didn't see any changes done after the first compilation.
    I haven't find a way to make it do all from the beginning.
    Any clue why this is happening?
    thanks, Miguel
  2. falko

    falko Super Moderator ISPConfig Developer

    Instead of deleting the kernel sources, you can stay in the kernel sources directory and run
    make clean && make mrproper
    before compiling again.

Share This Page