Ubuntu+ISPConfig+DKIM

Discussion in 'Installation/Configuration' started by oxygen, Mar 19, 2016.

  1. oxygen

    oxygen Member

    Finally all my records are ok (SPF, DKIM, DMARK).
    i did email test with score 8.8/10 at https://www.mail-tester.com
    my problem:

    -1.274 RDNS_NONE Delivered to internal network by a host with no rDNS
    This may be a false-positive, please check the reverse DNS test below to confirm or not this issue

    Your IP address 85.xxx.xxx.48 is associated with the domain 85-xxx-xxx-48.ip.kis.lt.
    Nevertheless your message appears to be sent from server.MYDOMAIN.com.

    You may want to change your pointer (PTR type) DNS record and the host name of your server to the same value.



    Here are the tested values for this check:
    • IP: 85.xxx.xxx.48
    • HELO: server.MYDOMAIN.com
    • rDNS: 85-xxx-xxx-48.ip.kis.lt
     
    ztk.me likes this.
  2. ztk.me

    ztk.me ISPConfig Developer ISPConfig Developer

    yes, rDNS and HELO have to match.
     
  3. oxygen

    oxygen Member

    Spoke with internet provider, he can't change PTR record, it's automatic for all users, so my server rDNS will be 85-xxx-xxx-48.ip.kis.lt anyway. Is there another way to make Helo same as rDNS without server renaming to 85-xxx-xxx-48.ip.kis.lt ?
     
  4. ztk.me

    ztk.me ISPConfig Developer ISPConfig Developer

    the only other way would be making the server send the correct helo then.
     
  5. oxygen

    oxygen Member

    So i should rename server from nice server.MYDOMAIN.com to nasty 85-xxx-xxx-48.ip.kis.lt :)?
     
  6. ztk.me

    ztk.me ISPConfig Developer ISPConfig Developer

    you only need to change the helo setting within postfix.
    Code:
    postconf -e smtp_helo_name=....ip.kis.lt
    maybe aswell
    postconf -e myhostname=....ip.kis.lt
    postconf -e smtpd_banner=....ip.kis.lt
    
    and reload postfix after
     
  7. oxygen

    oxygen Member

    tried this:
    postconf -e smtp_helo_name=....ip.kis.lt
    quality result was 1.2/10 because "we can't find any email server here:....ip.kis.lt (no A record)"
     
  8. ztk.me

    ztk.me ISPConfig Developer ISPConfig Developer

    dang, right ... didn't think of that :( well this is nothing you can change unfortunally :(
     
    oxygen likes this.
  9. oxygen

    oxygen Member

    Anyway, 8.8/10 is not bad result as well i think :)
     
    Last edited: Mar 23, 2016
  10. Jesse Norell

    Jesse Norell ISPConfig Developer Staff Member ISPConfig Developer

    Using your ip address as the helo hostname is perfectly valid:
    Code:
    postconf 'smtp_helo_name=[85.xx.xx.48]'
    I wouldn't expect that to change your mail-test.com results though, as RDNS_NONE should still fire because you don't have forward<->reverse dns matching.
    Your internet provider needs to add an A record to match the PTR record. Right now the PTR resolves to a name, but that name does not resolve to an address (mismatched or otherwise).
     
  11. florian030

    florian030 ISPConfig Developer ISPConfig Developer

    You can overwrite the hostname in the master.cf by adding " -o myhostname=anything.you.want" to any service.
    The default for smtp_helo_name and smtpd_banner is myhostname. There is no need to change various values.
     

Share This Page