Ubuntu Installation

Discussion in 'Installation/Configuration' started by SSK, Aug 7, 2020.

  1. SSK

    SSK Member

    I am facing an unusual situation where I could successfully install Ubuntu on an external drive. However, when I try to boot from the external drive, it is not working. This is not the first time that I have done this, but this is the first time when I am seeing this issue.

    The partition that I have on this external hard drive is:
    /dev/sdb1: fat32 (boot,esp) - labeled as EFI partition
    /dev/sdb2: linux swap
    /dev/sdb3: ext4

    For that matter, when I try to boot from EFI file, this particular drive is not even listed in the grub-boot options. Any suggestion to fix the issue would be appreciated.

    Also, I had another usb drive, which has been unmounted from the device, but it is still listed in the boot list. May I know what could be the reason for this and how to address it? Thanks.
  2. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    Where is grub installed?
    If during installation you install GRUB on that external (USB?) drive, it should boot from there.
  3. SSK

    SSK Member

    This is what the grub shows:
    Sourcing file `/etc/default/grub'
    Sourcing file `/etc/default/grub.d/init-select.cfg'
    Generating grub configuration file ...
    Found linux image: /boot/vmlinuz-5.4.0-42-generic
    Found initrd image: /boot/initrd.img-5.4.0-42-generic
    Found linux image: /boot/vmlinuz-5.3.0-28-generic
    Found initrd image: /boot/initrd.img-5.3.0-28-generic
    Found Ubuntu 18.04.4 LTS (18.04) on /dev/sda3 -------> this is the external drive that is not booting
    Adding boot menu entry for UEFI Firmware Settings
    sda3 is the ubuntu that was installed on this external drive. As mentioned, I have done this many times on internal and external drives including usb drives. Never had this issue before.
    ├─sda1 8:1 0 4.9G 0 part
    ├─sda2 8:2 0 16.1G 0 part
    └─sda3 8:3 0 1T 0 part
    Here are the grub files:
    /media/sda1drive/EFI/BOOT# ls -alZ
    total 4872
    drwxr-xr-x 2 root root ? 4096 Aug 6 19:44 .
    drwxr-xr-x 4 root root ? 4096 Aug 6 18:57 ..
    -rwxr-xr-x 1 root root ? 108 Aug 6 19:44 BOOTX64.CSV
    -rwxr-xr-x 1 root root ? 1334816 Aug 6 23:07 BOOTX64.EFI
    -rwxr-xr-x 1 root root ? 1213032 Aug 6 23:07 fbx64.efi
    -rwxr-xr-x 1 root root ? 126 Aug 6 19:44 grub.cfg
    -rwxr-xr-x 1 root root ? 1149312 Aug 6 19:44 grubx64.efi
    -rwxr-xr-x 1 root root ? 1269496 Aug 6 23:07 mmx64.efi
    Last edited: Aug 7, 2020
  4. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    Is sda the only disk on that host?
    What exactly happens when that host starts?
  5. SSK

    SSK Member

    sda is not the only drive. sda is the label that this removable drive gets on this device. Along with this one, on this particular device, there is the internal drive with multiple partitions. I also tried this removable drive on three different devices, along with different usb ports that are on this device and in all the scenarios, when I try to boot from the device, it tries to boot for sometime and switches automatically to the internal drive. That is why I also checked the grub myself for this drive. The first partition is also flagged as Boot and ESP, which should make the drive recognizable.

    UEFI and Legacy boots both are also enabled in the Bios settings.
  6. SSK

    SSK Member

    Quick update - I was able to boot this one from another multi-partition device. It makes me wonder how this is possible. I retried on previously tried devices without much success.

Share This Page