Ubuntu Installation Fails - ISPConfig

Discussion in 'Installation/Configuration' started by mateo107, Mar 4, 2006.

  1. mateo107

    mateo107 New Member

    Hi...

    I'm trying to run ISPConfig Installation for Ubuntu 5.1.0. I've run through the "installation script", following it percisely. The only problem is, I'm not getting an error when it gets to the PHP/Apache section of the installer, and it gives me an error that it won't work with my version of PHP.

    How do I completely remove the Apache/PHP support and then reinstall?
     
  2. falko

    falko Super Moderator

    First of all the errors you see refer to the Apache and PHP that come with ISPconfig, not to your main Apache and PHP. ISPConfig comes with its own Apache and PHP that serve the ISPConfig web interface on port 81 - it has nothing to do with your main Apache and PHP, and you must not remove them as they are requirements for ISPConfig!

    Can you post the exact error messages you get?
     
  3. mateo107

    mateo107 New Member

    Error

    the error appears to be stemming from this line:
    I've trapped as much of the installation errors that occur up to this point, where it then fails out, into the attached TXT file. Also, this occurs AFTER steps 6,7,8, where I appear to successfully create the RSA security certificates/keys.

    I'm VERY new to UBUNTU and Unix/Linux... so any/all suggestions would be greatly appreciated!
     

    Attached Files:

  4. falko

    falko Super Moderator

    Code:
    checking lex output file root... ./configure: line 3246: lex: command not found
    configure: error: cannot find output from lex; giving up
    Please install flex (yes, with an f at the beginning):
    Code:
    apt-get install flex
    and try again.
     
  5. mateo107

    mateo107 New Member

    I get this error when I try to run the flex install :(

    Any ideas how to fix this?
     
  6. till

    till Super Moderator

    This looks like a nameserver problem.

    Please try to run:

    apt-get update

    If you get similar errors, please check if your network connection to the internet is working and if the nameservers in /etc/resolv.conf are correct and reachable from your server.
     

Share This Page