ubuntu - init.d command not found

Discussion in 'Server Operation' started by sssdigital, Sep 3, 2007.

  1. sssdigital

    sssdigital New Member

    Just followed to install webmin at Ubuntu server, at command "sudo /etc/init.d/webmin start", which is displayed "command not found", pls any advise.
     
  2. falko

    falko Super Moderator ISPConfig Developer

    What's the output of
    Code:
    ls -l /etc/init.d
    ?
     
  3. sssdigital

    sssdigital New Member

    There's a lot of initscript but not have webmin. I could start webmin manually by "sudo /etc/webmin/start". Is there any step missed as I followed the step at here to set up webmin?
     
  4. falko

    falko Super Moderator ISPConfig Developer

    Did you get any errors during webmin installation?
     
  5. sssdigital

    sssdigital New Member

    Seems not. I just download ubuntu 7 server version & installed it into a reformated pc with LAMP, then following the step at here to install webmin. However, it could work by command "sudo /etc/webmin/start" but I try to install another program - tomcat & edit command with init. It's shown "command not found" too. Is any setting or step not complete when ubuntu is installed?
     
  6. c__chp

    c__chp New Member

    I have te same problem

    I also just installed ubuntu and the webmin via apt-get.
    i can now start the webmin manually
    but there is no entry in init.d
    How can i set my system in such a way that it will start at boot.

    or can any point me to some documentation in how to set up webmin on ubuntu
    Many Regards
    Nico Heiligers
     
  7. falko

    falko Super Moderator ISPConfig Developer

    You can place the command to start webmin in an init script (/etc/init.d/webmin), e.g. like this:
    Code:
    #!/bin/bash
    PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin
    your_command_to_start_webmin
    Make the script executable:
    Code:
    chmod 755 /etc/init.d/webmin
    and create the system startup links:
    Code:
    update-rc.d webmin defaults
     

Share This Page