Ubuntu Hardy server + OpenLDAP + Samba PDC. Simple question about groups.

Discussion in 'HOWTO-Related Questions' started by awe, Aug 31, 2009.

  1. awe

    awe New Member


    I have one question that may be silly, but still... I have a number of installations of Ubuntu 8.04 + Samba PDC + OpenLDAP for centralised authentication on the server, all working fine. In one of them, the worksations are Ubuntu 9.04. In a recent update of the worksations, sound capabilities disappeared in them and all sound was sent to Null Audio Output. PulseAudio does not seem to be running. All workstations authenticate correctly agains the LDAP server, and all users on the LDAP tree do not have any sound. There is one local user in each workstation (a local "PAM" user used for system administration only) and this user does have sound on each computer. Seemed to me like there was some sort of permission issue, i investigated, and found out that after some update users were joined to the "PulseAudio" groups 114, 115 and 116. This was automatically done by the update tool on the local PAM user, but was not done to the users in the LDAP tree.

    And here come my questions:
    - Can I make users of the LDAP tree to be members of more than one group?
    - How?
    I use LdapAdmin PHP scripts to manage the LDAP tree, and it will allow me to put only group per user.

    Sorry if the question is silly, but the problem is BIG. In this company they use Skype for contacting customers, so you can imagine the problem of not having sound... I pushed them to move from Windows to some free distro of Linux and I would not want to get into trouble because of my suggestion!
  2. matey

    matey New Member

    sorry I dont know any LDAP but Thanks for a useful post and I hope you get your answer quick,
    I was just wondering if you have tried to give (local) users more rights to /etc/pulse/ directory?(there are couple or more config files there )

    you can try and log in as a regular user to test it!

    Hopefully someone with the right answers will reply soon.
    good luck.
  3. matey

    matey New Member

    I think you should post this thread on different forums so you may get the right answer faster.

    In any case this is what I found out about PulseAudio:
    When I log in as my regular user I get this msg:

    But when I run it as root user I get this:

    So I am not sure if the system at the boot time installs the pulse-audio (drivers) with root privileges or
    it does not matter who logs in and what rights they have, it will work regardless?

    You can also do a
    /usr/bin/pulseaudio --help
    to see the diff. switches.
    good luck.
    (and please post the solution)
    Last edited: Sep 1, 2009
  4. awe

    awe New Member

    Well, it seems like I have a workaround that works for this particular installation, probably for other installations too.

    In a fresh installation of Jaunty, sound works for all users, including those that reside on the LDAP tree. It seems that sound for LDAP users goes with some particular update. I rememberd that one of the upgrades included PulseAudio, so I decided to do a fresh installation and then upgrade everything but PulseAudio. In this installation there is barely anything stored on the local hard disks, nearly all is stored on the server because all files that are worked on must be shared. So, easy, repartition the hard disks and reinstall the OS from scratch, there are almost no local files to backup. Then do all the upgrades ***EXCEPT*** PulseAudio, and disable upgrades. Reconfigure Samba and PAM to fetch users from the LDAP server. And all working. Then restored Evolution config (what a useful feature!), reinstalled the accounting software (simple double-click on a .deb file) and Skype, "et voilà". Apartment management software (they rent apartments) is just a set of PHP scripts on a server declared as a VirtualHost (works as a website) so nothing to install on workstations.

    I would not call this a solution, it is tedious and lengthy, but it works. I wonder what will happen when the time comes to upgrade to Ubuntu 9.10.

    And I leave a though to share with you. It is hard to make companies move to Linux. When they do, it's because they trust me and I must not leave them down. When I face situations like this, it makes me utter quite a few curses. I don't know who in Canonical (or wherever else) has coded an upgrade that left LDAP users without any sound, but:
    1) This person definetely did not think of corporate users. What other surprises can I have if Canonical thinks of private users only? I am very upset.
    2) If I met this person I'd have a word or two to say. Polite, but concise.
    Last edited: Sep 3, 2009

Share This Page