Ubuntu Dapper, PHP5, with openssl support

Discussion in 'Installation/Configuration' started by betdjibouti, Nov 1, 2006.

  1. betdjibouti

    betdjibouti New Member

    Sorry in advance for the long post. I still call myself a newb to all of this, so I don't know how much info is too much . . .

    I am searching far and wide to find out how I can install php5 with the openssl extension (http://www.php.net/openssl) on Dapper. There is no php5-openssl package (nor for debian, it seems).

    Downloading the source and peeking at php5sourcedir/debian/rules suggests that the package php5 should do the trick (--with-openssl=/usr \), but after apt-get install..., there is no openssl.so in /usr/lib/php5/20051025/ (where all the other php extensions are).

    I then (after the appropriate apt-get remove..., and apt-get build-dep php5), tried creating my own package (dpkg) with /debian/rules pointing to (on subsequent attempts):
    • /usr/lib/ssl
    • /usr/bin/openssl
    • /usr/include/openssl

    Each time, getting a configure error for openssl about not being able to find "evp.h". I even tried copying all the headers (from /usr/include/openssl) to /usr/lib/ssl and running it (then it said it could find any openssl headers ???).

    I finally tried making a package with --with-openssl (but no dir info), and the .debs were made. When I installed, however, it was as if I'd used apt (no openssl.so).

    I'm kind of at my wits end here. Any help would be most appreciated.
     
  2. falko

    falko Super Moderator ISPConfig Developer

    Are you sure there is no such package for Ubuntu 6.06? What's the output of
    Code:
    apt-cache search php
    ?
     
  3. betdjibouti

    betdjibouti New Member

    Thanks for the reply!

    Yep. I performed that search, as well as many different "advanced" searchs on packages.ubuntu.com (even searching the contents of all packages for openssl.so--which only yielded 2 results--both having nothing to do w/ php).

    However, one thing I did not try before is phpinfo(), which tells me that openssl support IS enabled (after an apt-get installation), even though there is no mention of ssl in any php.ini on the system. So, I'm presently investigating whether or not that is indeed the case. Is it possible that openssl support was made "native" to php after a certain version or something? I'll report back later.
     
  4. falko

    falko Super Moderator ISPConfig Developer

    Yes, that's possible, although I don't know for sure.
     
  5. betdjibouti

    betdjibouti New Member

    I promised an update, so here it is--that looks like it is indeed the case--there is no longer an openssl.so needed. I eventually 'solved' my issue by learning that php presently does not support certain versions of TLS--something to do with how php can use STARTTLS. Fortunately, I got around this by being able to switch to SSL.
     

Share This Page