Ubuntu dapper LTS and PHP 5.2

Discussion in 'Installation/Configuration' started by gzero, Feb 15, 2008.

  1. gzero

    gzero New Member

    Hi,

    I am running ispconfig on ubuntu dapper LTS. Because multiple projects (one of them is Drupal) are changing system requirements up to PHP 5.2 I will need to update my php to minimal 5.2. Currently Dapper LTS only supports PHP 5.1.2 which is not sufficient to run Drupal 7 in the future and CiviCRM with its new release 2.0 due 02/25/2008 I will be forced to update my PHP version if i want to upgrade CiviCRM to 2.0.
    Now my question is, what will be the best solution to this issue? Could I do a dist-upgrade on dapper without to many headaches or should I update PHP from another repository?

    Any help in this case appreciated.

    Carlo
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    The safer solution might be to update just php.

    I did dist-upgrades on debian and they work mostly fine (only small changes needed after the upgrade), but i never tried this on a ubuntu system.
     
  3. mozmac

    mozmac New Member

    I want to update just php, however, I don't know how. The Ubuntu repositories only let you upgrade php to 5.1.2. Can you recommend a repository that will let me upgrade it further?

    I am also on Dapper 6.06 server.
     
  4. falko

    falko Super Moderator ISPConfig Developer

    You could try to install the PHP5 packages from Gutsy. But please do this on your own risk!
     
  5. mozmac

    mozmac New Member

    I went ahead and installed PHP5 using packages from Edgy. I did so, however, with a quivering finger. Everything went well (so far) and I hope I don't run into any more problems. This is only a dev server.
     
  6. kozimodo

    kozimodo New Member

    How did that work out? I have the same problem.
     

Share This Page