ubuntu configure dns-nameserver pointer on eth0

Discussion in 'Installation/Configuration' started by bellbuk, May 30, 2008.

  1. bellbuk

    bellbuk New Member


    First time posting, so I hope I get the problem across ok.

    Using VMware workstation on WinXp. I've installed an Ubuntu 7.10 server to act as a firewall hooked up to the vmware bridge. If I ping, for example, news.bbc.co.uk, I get a positive response, so I know this server is working OK. I can also run apt-get update and it responded ok.

    I then created a 2nd Ubuntu 7.10 server sitting inside the firewall (it's to represent a DMZ web server) It can ping across the firewall server no problems. If I ping the ip address for news.bb.co.uk, it responds OK. If I ping news.bbc.co.uk, it comes back with unknown host. I suspect that this means that the server inside the firewall cannot access a DNS server to convert the URL to an ip address. In the file /etc/network/interfaces, I've added the line dns-nameserver to the eth0 definition, bounced eth0, but still getting the same result. Also apt-get update gives an error on everyline because it can't locate the security.ubuntu.com site, giving the error message "temporary failure resolving security.ubuntu.com/....". This worked fine on the firewall server.

    Can anyone shed some light on what I'm doing wrong here.

    Much appreciated.
  2. falko

    falko Super Moderator ISPConfig Developer

    What's in /etc/resolv.conf?
  3. bellbuk

    bellbuk New Member

    Hi Falko,

    Thanks for the response. Sorry it's taken a while to get back but this is a setup that I'm doing in my spare time.

    The resolv.conf was the issue. On the server, the file was empty. Had a look in the firewall copy and made the server the same, i.e. it should point to the ADSL router's lan address.

    This seems to have fixed it as last night I was able to run 'apt-get upgrade' on the server without DNS issues.

    Many thanks.

    Best regards

Share This Page