Ubuntu 9.10 add screen resolution

Discussion in 'Installation/Configuration' started by Twinkie, Nov 15, 2009.

  1. Twinkie

    Twinkie New Member

    The idea here is that my Dell Latitude D520 can support a much greater desktop resolution and I need to finish making this laptop look good for the boss. This is another hurdle keeping Windows on these computers to me. If I get this one working I will do the same on a Latitide D630 next. My background is Windows guy who switched to ubuntu about 2 years ago on every computer I can now. Hopefully I will understand all the helpful comments I get back here. Thanks in advance.

    $sudo lshw

    *-display:0

    description: VGA compatible controller

    product: Mobile 945GM/GMS, 943/940GML Express Integrated Graphics Controller

    vendor: Intel Corporation

    physical id: 2

    bus info: pci@0000:00:02.0

    version: 03

    width: 32 bits

    clock: 33MHz

    capabilities: msi pm bus_master cap_list rom

    configuration: driver=i915 latency=0

    resources: irq:16 memory:eff00000-eff7ffff ioport:eff8(size=8) memory:d0000000-dfffffff(prefetchable) memory:efec0000-efefffff

    *-display:1 UNCLAIMED

    description: Display controller

    product: Mobile 945GM/GMS/GME, 943/940GML Express Integrated Graphics Controller

    vendor: Intel Corporation

    physical id: 2.1

    bus info: pci@0000:00:02.1

    version: 03

    width: 32 bits

    clock: 33MHz

    capabilities: pm bus_master cap_list

    configuration: latency=0

    resources: memory:eff80000-efffffff


    $ xrandr

    Screen 0: minimum 320 x 200, current 1024 x 768, maximum 4096 x 4096

    VGA1 disconnected (normal left inverted right x axis y axis)

    LVDS1 connected 1024x768+0+0 (normal left inverted right x axis y axis) 304mm x 228mm

    1024x768 60.0*+

    800x600 60.3

    640x480 59.9

    DVI1 disconnected (normal left inverted right x axis y axis)

    TV1 disconnected (normal left inverted right x axis y axis)


    $ cvt 1280 1024 60

    # 1280x1024 59.89 Hz (CVT 1.31M4) hsync: 63.67 kHz; pclk: 109.00 MHz

    Modeline "1280x1024_60.00" 109.00 1280 1368 1496 1712 1024 1027 1034 1063 -hsync +vsync


    $ xrandr --newmode "1280x1024_60.00" 109.00 1280 1368 1496 1712 1024 1027 1034 1063 -hsync +vsync


    $ xrandr --addmode LVDS1 "1280x1024_60.00"
    X Error of failed request: BadMatch (invalid parameter attributes)

    Major opcode of failed request: 149 (RANDR)

    Minor opcode of failed request: 18 (RRAddOutputMode)

    Serial number of failed request: 27

    Current serial number in output stream: 28


    Running clean install of Ubuntu 9.10 and there is no /etc/X11/xorg.conf file nor can I find the xorg.conf anywhere else on my system. Any ideas?
     
  2. falko

    falko Super Moderator

  3. moonspa

    moonspa New Member

    Hi,

    Same happend to me also (it was Ubuntu desktop 9.10 x64) when I tried add new mode as root (sudo -i). After I logged out to my regular user account "xrandr --addmode" finished successfully.

    Hint:
    Also ensure yourself that new resolution which was created with command "xrandr --newmode" really exists. This can be done when you call just "xrandr" without arguments. You should see it in output list.


    Cheers,
    mOOnSPa.
     

Share This Page