Ubuntu 9.04 [ISPConfig 3] - Step 12: Broken packages: sendmail, rmail

Discussion in 'HOWTO-Related Questions' started by HorseArcher, Jul 29, 2010.

  1. HorseArcher

    HorseArcher New Member

    Hi all,

    I'm working on a virtual server under OpenVZ and installing the packages described in Step 12, and aptitude is telling me that two packages are broken: rmail sendmail

    It offers a couple of alternatives, if I choose not to accept its solution, but they all leave postfix uninstalled.

    root@www:/# aptitude install postfix postfix-mysql postfix-doc mysql-client mysql-server courier-authdaemon courier-authlib-mysql courier-pop courier-pop-ssl courier-imap courier-imap-ssl libsasl2-2 libsasl2-modules libsasl2-modules-sql sasl2-bin libpam-mysql openssl maildrop getmail4 rkhunter binutils 
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    Reading extended state information      
    Initializing package states... Done
    The following packages are BROKEN:
      rmail sendmail 
    The following NEW packages will be installed:
      courier-authdaemon courier-authlib{a} courier-authlib-mysql courier-authlib-userdb{a} courier-base{a} 
      courier-imap courier-imap-ssl courier-pop courier-pop-ssl courier-ssl{a} expect{a} gamin{a} getmail4 
      libdbd-mysql-perl{a} libdbi-perl{a} libgamin0{a} libhtml-template-perl{a} libmd5-perl{a} libnet-daemon-perl{a} 
      libpam-mysql libplrpc-perl{a} libsasl2-modules-sql libsqlite0{a} libterm-readkey-perl{a} maildrop mysql-client 
      mysql-client-5.0{a} mysql-server mysql-server-5.0{a} mysql-server-core-5.0{a} postfix postfix-doc postfix-mysql 
      python-support{a} rkhunter tcl8.4{a} unhide{a} 
    The following packages will be REMOVED:
    0 packages upgraded, 37 newly installed, 1 to remove and 0 not upgraded.
    Need to get 42.6MB of archives. After unpacking 127MB will be used.
    The following packages have unmet dependencies:
      sendmail: Depends: sendmail-bin but it is not installable
      rmail: Conflicts: postfix but 2.5.5-1.1 is to be installed.
    The following actions will resolve these dependencies:
    Remove the following packages:
    Score is 192
    Accept this solution? [Y/n/q/?] n   
    The following actions will resolve these dependencies:
    Keep the following packages at their current version:
    postfix [Not Installed]
    postfix-mysql [Not Installed]
    sendmail-bin [8.14.3-6 (jaunty, now)]
    Score is -19743
    Any ideas?

  2. kwickcut

    kwickcut Member

    did you do the step 8 Edit /etc/apt/sources.list And Update Your Linux Installation

    Accept this solution? [Y/n/q/?] n
    i think you should have entered yes

  3. HorseArcher

    HorseArcher New Member

    Yes, I did update sources.list and my installation. I've accepted the solution and completed the installation. I'll report back, once I've verified mail, etc.

    Thanks for the assist, Kwick.

Share This Page