Ubuntu 9.04 and IspConfig 3

Discussion in 'HOWTO-Related Questions' started by Emrulez, Apr 30, 2009.

  1. Emrulez

    Emrulez New Member

    I saw an how to with ispConfig 2 is there one with evrsion 3?

    If not will there be one?

    Thanks In Advance,

  2. falko

    falko Super Moderator ISPConfig Developer

    Not yet.

  3. ValeMax

    ValeMax New Member

    dovecot instead of courier - vsftpd instead others

    Falko, thanks for your excellent works, can i ask why don't you use dovecot and vsftpd in your tutorials?
    They are listed as a possible services in ISPConfig requirements.

    Bye :)
  4. falko

    falko Super Moderator ISPConfig Developer

    If I used Dovecot and vsftpd, then other people would aks why I don't use Courier and Proftpd... ;)
  5. ValeMax

    ValeMax New Member

    Ok, yoy're right, I did wish know if your experience suggested one software over another one, due problems, easy of install/use, etc.
  6. emadfathy

    emadfathy New Member

    ISPConfig on Ubuntu 8.04 LTS

    First, I want to thank Falko very much for this great software.
    Second, I searched for the guide to install ISPConfig3 on Ubuntu 8.04 and did't found so i started with Perfect-server-ubuntu-8.10-ispconfig-3 as a guide and expect some minor changes and it happened and it was easy to cover, you can do the same Emrulez.
  7. safoo

    safoo New Member


    can you list the differences? I'm doing the same thing you did, that is use that tutorial for 8.04. I would imagine it would be nearly the same.
  8. falko

    falko Super Moderator ISPConfig Developer

  9. emadfathy

    emadfathy New Member

    I didn't wrote down the changes because i expect no changes.

    As i remember...
    1- In step 14 there is no package named "apache2-suexec" and you will get warning about this,but don't care, the module will be installed (i guess it included in another package).
    2- In the same step don't run "a2enmod suexec rewrite ssl actions include" but run the command individually for each module
    a2enmod suexec
    a2enmod rewrite
    3- After reboot i got a message that the bastille-firewall can't create a file and this happen because a folder dose not exists you can correct this by adding a command to create the missing folder in /etc/init.d/bastille-firewall script
    put this line befor the last switch case in the script.
    mkdir /var/run/lock/subsys
    I don't remember other important difference

    Make sure your start guide depend on ISPConfig3 not 2 because each version may different in requirments.

    Final notice : I didn't put this server in production yet.
    Last edited: May 6, 2009
  10. roi

    roi New Member


    Why do I need MyDNS on the server ? (or any DNS server on the servers)?
    I have two stand alone DNS servers, running powerdns.
    Is it just for a configuration from ISPconfig ?
  11. falko

    falko Super Moderator ISPConfig Developer

    They must be installed, however you don't need to run them.
  12. Emrulez

    Emrulez New Member

    Yep I found it ;)

    I just installed vereything yesterday.

    Got evreythiong working except mydns.

    ISPConfig says its not running.

    What did I do wrong?

    Thanx In Advance

    P.S: I used ecserver.gotdns.com instead of server1.example.com
  13. Emrulez

    Emrulez New Member

    So when i go to ecserver.gotdns.com I am redirected to my router is that supposed to happen? I am kinda new to this.
  14. roi

    roi New Member

    They must be installed in order for ISPconfig 3 to run properly, and there is no technical reason for them apart from this.
  15. falko

    falko Super Moderator ISPConfig Developer

    You must configure your router to forward the ports (80, 8080, etc.) to your server.
  16. gawehner

    gawehner New Member

    I have been following the Perfect Server for Ubuntu 9.04 with ISPConfig3 how-to. So far I have enjoyed success - however the system monitor shows 1 warning and 1 error. MyDNS is offline and ClamAV needs to be updated. From the above quote, can I now disregard the MyDNS error? Is there anyway to get ISPConfig to ignore it? I have tried to update ClamAV, but the message will not go away. Thank you for you're wonderful site.

    Greg Wehner
  17. falko

    falko Super Moderator ISPConfig Developer

    What's the output of
    netstat -tap

    How did you try to update ClamAV?
  18. gawehner

    gawehner New Member

    Here is my netstat results:

    Active Internet connections (servers and established)
    Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
    tcp 0 0 localhost:##### *:* LISTEN -
    tcp 0 0 localhost:##### *:* LISTEN -
    tcp 0 0 *:mysql *:* LISTEN -
    tcp 0 0 localhost:spamd *:* LISTEN -
    tcp 0 0 *:http-alt *:* LISTEN -
    tcp 0 0 *:www *:* LISTEN -
    tcp 0 0 *:ftp *:* LISTEN -
    tcp 0 0 *:ssh *:* LISTEN -
    tcp 0 0 *:smtp *:* LISTEN -
    tcp 0 0 *:https *:* LISTEN -
    tcp 0 ### Hostname.mysite.com:ssh Foreign Address ESTABLISHED -
    tcp6 0 0 [::]:imaps [::]:* LISTEN -
    tcp6 0 0 [::]: pop3s [::]:* LISTEN -
    tcp6 0 0 [::]: pop3 [::]:* LISTEN -
    tcp6 0 0 [::]:imap2 [::]:* LISTEN -
    tcp6 0 0 [::]:ftp [::]:* LISTEN -
    tcp6 0 0 [::]:ssh [::]:* LISTEN -

    I also checked for the process with ps -ef | grep mydns with 0 results.

    Is there a manual method to start the server? I looked at the permissions on the script in /etc/init.d/mydns and they allow execution.

    As for ClamAV, I misread the log files - the MyDns offline is the only message I am currently getting on my ISPConfig monitor. Thank you.
  19. falko

    falko Super Moderator ISPConfig Developer

    Please run
    /etc/init.d/mydns start 
  20. gawehner

    gawehner New Member

    Following the "The Perfect Server - Ubuntu 9.04 [ISPConfig 3]" HOW-TO, where should mydns install to? I copied the provided script to /etc/init.d, set it to excute, updated the paths and ran it, but nothing happened. Reading through the script it looks like it's pointing to /usr/(bin,sbin,local,etc) paths - but mydns is not in any of those directories. Is it possible I didn't install it properly from the start? If so, now that ISPConfig is already running, can I install mydns after the fact successfully? Thank you for your prompt follow up.

    PS - I found another thread on this issue "ISPConfig3 myDNS -Server Offline?" and tried following some of the advice offered there to no avail.


Share This Page