ubuntu 8.04 server installation of ispconfig fails

Discussion in 'Installation/Configuration' started by DocProc, May 3, 2008.

  1. DocProc

    DocProc New Member

    Hello there...


    i'm just setting up a ubuntu 8.04 server (alternate install cd) and followed the "perfect server setup" to the letter (!) but the installation of ispconfig fails with the following error (see below)

    is there anyone who can help me?

    thanks a lot in advance!

    Doc

     
  2. hyperionza

    hyperionza New Member

    Ive got the same problem on Ubuntu 7.10, server edition. also followed the perfect server setup to the letter, and got the same error, just in English: the PHP module that comes with ISPConfig is not compatible with your system. the installation ends here! <- something like that.
     
  3. falko

    falko Super Moderator

    What's the output of
    Code:
    uname -a
    ?
     
  4. till

    till Super Moderator

    @hyperionza: the error message you mentioned is not specific to a error, it is displayed for every installation error. What we need to know is the first error an not the last error message, like DocProc posted it in this thread.
     
  5. DocProc

    DocProc New Member

    hi falco

    uname -a produces:

     
  6. falko

    falko Super Moderator

    Ok, no 64bit system. I think it could have to do with your gcc version. You can try to install another version and then try the ISPConfig installation again.
     
  7. DocProc

    DocProc New Member

    Hi Falco

    What do you mean by "another version"?

    I installed the standard personal computer version of ubuntu server 8.04 alternate CD due to the fact that my pc is an older Pentium... If it isnt a 64bit system I cant install one, can I?

    Greetz

    Doc
     
  8. falko

    falko Super Moderator

    What's the output of
    Code:
    apt-cache search gcc
    ?
     
  9. DocProc

    DocProc New Member

    it says the following:

     
  10. falko

    falko Super Moderator

    You could try this:
    Code:
    apt-get install gcc-3.4
    Then try to install ISPConfig again.
     
  11. DocProc

    DocProc New Member

    Hi Falco

    your suggestion did work... thank you! i pass the error it now, just to get another abortion... i really dont get it, i followed the install guide to the letter... do i make a general mistake?

    the now occuring exception is the same, but shows up way later in the setup routine and the error messages says:

     
  12. flipkick

    flipkick HowtoForge Supporter

    Hi DocProc

    Install the requested header files:

    Code:
    sudo apt-get install libmysqlclient15-dev
    
    cheers,
    flip
     
    Last edited: May 8, 2008
  13. DocProc

    DocProc New Member

    Thanks flip,

    we are getting closer (thanks to the help of you guys!!)

    now i pass the 2nd error, but get this one (missing spamassassin? (regarding the perfect server setup it says "ispconfig comes with spamassassin" (or somethin like that)):

     
  14. flipkick

    flipkick HowtoForge Supporter

    another segmentation fault... strange system ;) if gcc3.4 doesn't work, then try 3.3:

    Code:
    sudo apt-get install gcc-3.3
    
    and reinstall ispconfig.

    cheers,
    flip
     
  15. DocProc

    DocProc New Member

    hi flipkick,

    sorry for answering that late to your post, but i got a lot to do at work...

    i tried gcc 3.3 but it creates the following error:

    sooner or later ill get really mad :confused:

     
  16. flipkick

    flipkick HowtoForge Supporter

    just read the error message. you haven't installed openssl. you said you've followed the "perfect system" tutorial. well, no, you actually haven't. otherwise all needed packages would already be installed. like the mysql dev package or the openssl package.
     
  17. navop

    navop New Member

    Having the same problem, going to re-install ubuntu server again, and going to follow this link closely
     
  18. DocProc

    DocProc New Member

    hi flipkick

    i just went through the whole 'perfect server' setup... u were right, accidentally i did the one for ubuntu 7, not 8... *dont say anything ;)*

    so i get as far as never before, but still thr installation of ispconfig fails... i really dont know waht to to... honestly, i followed the correct (!) server setup to the letter... ;(

    ah, and here's the error message:

     
  19. zarrelli

    zarrelli New Member

    Just to mention,

    I installed ISPConfig on an Ubuntu 8.04 server 64 bit and I didn't find big problems so far. Just the usual spamassassing eating feature and some Per libs warnings.

    I have some sites up, mail, web and ftp.
     
  20. flipkick

    flipkick HowtoForge Supporter

    There's definitely something wrong with your hardware system or linux installation. It could happen that newer GCC versions have problems with older systems, but GCC 3 should always work.
     

Share This Page