Ubuntu 7.10 + Postfix+Courier+Mysql - Cannot receive external smtp emails

Discussion in 'HOWTO-Related Questions' started by patrickzfr, Mar 11, 2008.

  1. patrickzfr

    patrickzfr New Member

    Hi to everybody!
    First, all my congratulations for this site :eek: . It is a great source of informations and it helped me a lot already!
    Here is my question:
    I have installed Postix and additionnal packages following the
    "Virtual Users And Domains With Postfix, Courier And MySQL (Ubuntu 7.10)" Howto (with courier Pop, not Imap).
    After some adjustments, all works fine :) . I can send and receive internal emails to and from the users declared in the mail database, forwarding works fine too, and I can retrieve the emails from external Internet connections from external "Outlook" users with pop connections to my server.

    But... One only thing doesn't work! It is impossible to receive emails from external users, sending their emails by smtp.

    My Postfix SMTP give "access denied" "Client host rejected" to this smtp connection (I have put "xxx" in place of real names:

    Reporting-MTA: dns; smtp3-g19.free.fr
    X-Postfix-Queue-ID: 4DBF617B565
    X-Postfix-Sender: rfc822; [email protected]
    Arrival-Date: Tue, 11 Mar 2008 11:42:31 +0100 (CET)
    Final-Recipient: rfc822; [email protected]
    Action: failed
    Status: 5.0.0
    Diagnostic-Code: X-Postfix; host pa.xxx.fr[82.xxx.xx.32] said: 554 5.7.1
        <smtp3-g19.free.fr[]>: Client host rejected: Access denied (in reply to RCPT TO command)
    My mail.log says :

    Mar 11 11:42:31 linux-shuttle postfix/smtpd[7036]: connect from smtp3-g19.free.fr[]
    Mar 11 11:42:31 linux-shuttle postfix/smtpd[7036]: NOQUEUE: reject: RCPT from smtp3-g19.free.fr[]: 554 5.7.1 <smtp3-g19.free.fr[]>: Client host rejected: Access denied; from=<[email protected]> to=<[email protected]> proto=ESMTP helo=<smtp3-g19.free.fr>
    Mar 11 11:42:32 linux-shuttle postfix/smtpd[7036]: disconnect from smtp3-g19.free.fr[]
    It seems there is a wrong parameter somewhere to allow external smtp connections ... but I don't know where!

    I guess it is some smtpd_recipient_restrictions parameters in main.cf ??

    Currently I have:

    smtpd_recipient_restrictions = permit_mynetworks, permit_sasl_authenticated, reject_unauth_destination

    Any ideas?
    thanks in advance for your help.
    Last edited: Mar 11, 2008
  2. patrickzfr

    patrickzfr New Member

    I found it :D

    The line
    -o smtpd_client_restrictions=permit_sasl_authenticated,reject

    in my master.cf file was not commented, so the restriction to client was in use and blocked all external client connections..

    So, all ok now .. cross my fingers :)

Share This Page