Ubuntu 6.10 apache2-mpm-worker and php5

Discussion in 'HOWTO-Related Questions' started by danielos, Jun 28, 2007.

  1. danielos

    danielos New Member

    I'm facing a strange problem, I have installed:
    apt-get install apache2 apache2-common apache2-doc apache2-mpm-worker apache2-utils libapr0 libexpat1 ssl-cert

    and then
    apt-get install libapache2-mod-php5 php5 php5-common

    then I get:

    The following packages will be REMOVED:
    apache2-mpm-worker
    The following NEW packages will be installed:
    apache2-mpm-prefork libapache2-mod-php5 libxml2 php5-common


    But I don't want to remove apache2-mpm-worker, does'nt the worker work with php5?

    All help appreciated :)
     
  2. falko

    falko Super Moderator ISPConfig Developer

    The PHP5 module (libapache2-mod-php5) works only with apache2-mpm-prefork.
    If you want to install apache2-mpm-worker, you must use the CGI version of PHP.
     

Share This Page