Ubuntu 6.06 LTS with MySQL Client Version 5 - Steps

Discussion in 'Installation/Configuration' started by mark.b, Feb 12, 2008.

  1. mark.b

    mark.b New Member

    Hello Falco, hello Till

    after testing the perfect setup for UBUNTU 6.06.2 SERVER LTS and reading this forum for two weeks now I am asking me if the following steps are correct also for future ISPconfig updates (at this moment it seems all is working perfectly).

    I used the 6.06.2 version because of the support (2011) but also want the mysqlclient version 5 package.

    As read in this forum and tested by myself the ISPconfig Setup (2.2.18 and 2.2.19) can not be installed with the libmysqlclient15-dev package on ubuntu 6.06.2. ...anyway.

    So I used the Perfect Setup for Ubuntu 6.06 with libmysqlclient12-dev. After patching the 2.2.19 version (gcc bug) from the following thread
    http://www.howtoforge.com/forums/showthread.php?t=19222 and using the standard definitions for the cert I was able to make a clean install.

    I must always (2.2.18 and 2.2.19) generate the cert after the installation
    http://www.howtoforge.com/forums/showthread.php?t=19754 but then all is working out of the box :)

    Then I updated the mysqlclient version with the libmysqlclient15-dev package and started another installation from the "gcc patched" 2.2.19 installation files. So I think this second installation made a normal update of the working structure.

    In the end I have a ISPconfig 2.2.19 version with mysqlclient version 5 starting without any errors :D

    So am I right that this will also work for the next updates of ISPconfig ?

    Thanks for your time answering so many questions in your forum :rolleyes:

    PS: I am not a data base specialist. But why are so many warnings in the ispconfig db like
    "The following indexes appear to be equal and one of them should be removed: PRIMARY, tree_id_2"
    Can this be ignored ?
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    The perfect setup guide is working fine if you foillow it exactly. If you install other software pacakges and do not follow the guide, it may lead to errors of course.

    The ISPConfig mysal databse is fine, you can ignore the warnings.
  3. mark.b

    mark.b New Member

    Hello Till,

    thanks for the quick reply. But now I am a bit confused.

    Your answer is correct of course. As I wrote the Perfect Ubuntu 6.06 Setup works flawlessly :)

    My question belongs to the package installation AFTER the first working ISPconfig installation. So the second ISPconfig Installation as an update seems to work now with the libmysqlclient15-dev without any problems.

    Five minutes ago I updated to the version 2.2.21 and tested some new entries for clients, sites and databases. No problems here...

    Or do you mean the combination of ubuntu 6.06 and libmysqlclient15-dev is generally not supported by ISPconfig ?!
    Not for installation (I know that) but also not with the described update trick ?

    I am asking this because we need an official supported system for vmware server (not workstation nor esx server). Debian is not listed and Open Suse got me too much trouble at the perfect installation guide as we always need additional packages for the vmware tools installation and the used backup program.

    But if you say this is not a working combination I have to deal with a newer distribution and experimental support in vmware server.
    Thats of course not your problem ;)

    Thanks again
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    ISPConfig works with evyer libmysqlclient version, so thats not a question of ISPConfig. You just have to install the mysqöl client libararies that correspoind with the version of the mysql server that you installed.

Share This Page