Ubuntu 6.06 LTS Server issues

Discussion in 'Installation/Configuration' started by strix, Apr 1, 2008.

  1. strix

    strix New Member

    Hello,
    I installed and configured Ubuntu 6.06 LTS Server + ISPConfig as described in this tutorial and everything is running perfect. I host 4 domains on a single static IP, two of them have 3 mail users, but I have some questions:

    1. I need webmail access for all 4 domains. I apt-get-ed squirrelmail, but don't know how to configure it to work with 4 domains.

    2. I need a directory with directory listing to put some stuff for easy downloading. I followed this thread and created dir with .htaccess file in with:
    Code:
    Options +Indexes
    I also enabled +Indexes, AllowOverride All and Allow from all in /etc/apache2/apache2.conf:
    Code:
    <Directory /var/www/*/user/*/web>
        Options +Includes [COLOR=DarkRed][B]+Indexes[/B][/COLOR]
        AllowOverride [COLOR=DarkRed][B]All[/B][/COLOR]
        AllowOverride Indexes AuthConfig Limit FileInfo
        Order allow,deny
        Allow from all
        <Files ~ "^\.ht">
        [COLOR=DarkRed][B]Allow from all[/B][/COLOR]
        </Files>
    </Directory>
    
    but still have 500 error - Internal Server Error!
    In /var/www/ there is no .htaccess file for Options to be inherited.

    In /var/www/web2/error.log:
    Code:
    ................
    [Tue Apr 01 02:49:49 2008] [error] [client 192.168.160.1] Directory index forbidden by rule: /var/www/web2/web/downloads/
    [Tue Apr 01 02:50:34 2008] [alert] [client 192.168.160.1] /var/www/web2/web/downloads/.htaccess: Options not allowed here
    ................
    
    Any help will be apreciated.
     
  2. Leszek

    Leszek New Member

    You should remove the Squirrelmail package and use one (or every one) of the third party tools and add-ons described here: http://ispconfig.org/downloads.htm
    Squirrelmail,Telaen Webmail and RoundCube are available.
    You can install it by ISPConfig's web interface (Management-->Update).
     
  3. strix

    strix New Member

    Remove pass phrase on reboot?

    The server wants to enter a pass phrase every time when start. How to avoid that?
    Code:
    ..........
    Starting ISPConfig system...
    Apache/1.3.41 mod_ssl/2.8.31 (Pass Phrase Dialog)
    Some of your private key files are encrypted for security reasons.
    In order to read them you have to provide us with the pass phrases.
    
    Server [URL="http://www.somedomain.com"]www.somedomain.com[/URL]:81 (RSA)
    Enter pass phrase:
    
     
  4. Leszek

    Leszek New Member

    A quote of the installation instructions from http://ispconfig.org/manual_installation.htm:
     
  5. strix

    strix New Member

    Thank you!

    Thanks for pointing me which files are encrypted. Here is the solution for unencrypting them:
    They are in directory:
    Code:
    cd /root/ispconfig/httpd/conf/ssl.key
    ...and will be unencrypted with following steps:
    Code:
    openssl rsa -in ca.key -out newca.key
    Enter pass phrase:
    
    mv ca.key ca.key-encrypted
    mv newca.key ca.key
    
    openssl rsa -in server.key -out newserver.key
    Enter pass phrase:
    
    mv server.key server.key-encrypted
    mv newserver.key server.key
    
    Then you may test if passphrase is needed by:
    Code:
    /root/ispconfig/httpd/bin/apachectl stop
    /root/ispconfig/httpd/bin/apachectl startssl
    
    Is that simple.
    :)
     

Share This Page