Ubuntu 6.06 LTS ISP Server Setup with DTC

Discussion in 'HOWTO-Related Questions' started by seadap06, Sep 21, 2006.

  1. seadap06

    seadap06 New Member

    Not as easy as it appears. I am getting stuck with the last part:

    Actually, the cvs version is 0.22 now. I get all the way through setting up the mysql passwords, pear update etc and the fails saying

    If I fake a cli directory and copy the php.ini from php5 I get past that point but then fails saying:
    where XXXXXXX is the password I entered for mysql root instead of a valid user.

    I've tried to apt-get remove dtc, apt-get --purge remove dtc, dpkg -r dtc and reinstalling using the cvs and the apt-get but it still shows the root password instead of the root account.

    What am I missing here? Or better yet, should I use a different control panel? I've tried in vain to get ISPconfig working either.

    Thanks!

    Scott
     
  2. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    Did you install a command-line PHP (php-cli)? I think it's missing on your system.
     
  3. drunkenmugsy

    drunkenmugsy New Member

    Dtc

    Im having same problem with DTC. It looks nice and seems to do more than ISPconfig so I thought I would try it. No go. The install does php5, the error is asking for php4 maybe?
     
  4. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    I doubt it. :D
     
  5. biffnix

    biffnix New Member

    Has there been a resolution to this issue? I have the same problem

    root@localhost:~/dtc/bin# dpkg -i dtc_0.24.0-0_all.deb

    (Reading database ... 32353 files and directories currently installed.)
    Preparing to replace dtc 0.24.0-0 (using dtc_0.24.0-0_all.deb) ...
    ===> Uninstalling ports.conf
    ===> Uninstalling inclusion from courier authdaemonrc
    ===> Uninstalling inclusion from dovecot.conf
    ===> Uninstalling inclusion from proftpd.conf
    ===> Uninstalling inclusion from postfix/main.cf
    ===> Uninstalling inclusion from postfix/master.cf
    ===> Uninstalling inclusion from amavis/amavisd.conf
    ===> Uninstalling inclusion from postfix/sasl/smtpd.conf
    ===> Uninstalling from qmail
    ===> Uninstalling inclusion from /etc/sudoers
    ===> Uninstalling inclusion from /etc/shells
    ===> Uninstalling inclusion from /etc/ssh/sshd_config
    ===> Uninstalling inclusion from /etc/nss-mysql.conf
    ===> Uninstalling inclusion from /etc/nss-mysql-root.conf
    ===> Uninstalling inclusion from /etc/nsswitch.conf
    Unpacking replacement dtc ...
    Setting up dtc (0.24.0-0) ...
    ===> Installing modifications in php.ini
    grep: /etc/php4/cli/php.ini: No such file or directory
    Your php.ini doesn't has pear in it's inc path: changin!
    /var/lib/dpkg/info/dtc.postinst: line 228: /etc/php4/cli/php.ini: No such file or directory
    dpkg: error processing dtc (--install):
    subprocess post-installation script returned error exit status 1
    Errors were encountered while processing:
    dtc

    Any ideas?

    Joe G.
    Bishop, CA
     
  6. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    I think you must install the php-cli package.
     
  7. asem34

    asem34 New Member

    Falko:

    I run into several problems with this HOW-TO, and would be nice if these 8most of them) are updated properly.

    Here is one
    ------------------------------------------------------------------------
    In the line
    apt-get install postfix postfix-mysql courier-base courier-pop courier-imap courier-authdaemon courier-maildrop courier-authmysql courier-ssl courier-imap-ssl courier-pop-ssl sasl2-bin libsasl2 libsasl2-module

    the libsasl2-module does not get installed . does not exist in the repositories
    -----------------------------------------------------------------------

    In the next line

    rm /var/spool/postfix/var/run/saslauthd/
    ln -s /var/run/saslauthd /var/spool/postfix/var/run

    Cannot rm since the object does not exist and cannot lm since the item does not exist either.

    -------------------------------------------------------------------------

    Then, if I ignore these, the same problem with DTC as posted above.

    Can you help please?

    Cheers
     
  8. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    Does your sources.list look exactly like the one in the tutorial?
     
  9. asem34

    asem34 New Member

    There is no source.list in the tutorial
     
  10. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    Oh, you're referring to a different tutorial. Well, then make sure the uiverse repository is enabled in /etc/apt/sources.list. Run
    Code:
    apt-get update
    after any modification of that file.
     

Share This Page