Ubuntu 20.04 php-fpm sock failed (13: Permission denied)

Discussion in 'Installation/Configuration' started by Slawka, Jan 8, 2021.

  1. Slawka

    Slawka New Member

    Code:
    [crit] 816#816: *3 connect() to unix:/var/run/php/web2.sock failed (13: Permission denied) while connecting to upstream, client: 10.20.30.100, server: eth0, request: "GET / HTTP/1.1", upstream: "fastcgi://unix:/var/run/php/web2.sock:", host: "eth0"
    
    Code:
     cat /etc/php/7.4/fpm/pool.d/web2.conf
    [web2]
    
    listen = /var/run/php/web2.sock
    listen.owner = web2
    listen.group = apache
    listen.mode = 0660
    
    user = web2
    group = client0
    
    pm = dynamic
    pm.max_children = 10
    pm.start_servers = 2
    pm.min_spare_servers = 1
    pm.max_spare_servers = 5
    pm.max_requests = 0
    
    
    How to change through the web interface listen.group = apache
     
  2. nhybgtvfr

    nhybgtvfr Active Member

    i'm not sure how you got those settings, did you copy those files over from an ispconfig server on a different linux distro?

    i have quite a few ubuntu ispconfig servers (18.04 and 20.04), and on all of those
    where you have listen.group = apache, i have listen.group = www-data
    and listen = /var/run/php/web2.sock would be /var/lib/php7.4-fpm/web2.sock (20.04), or /var/lib/php7.2-fpm/web2.sock (18.04)

    without knowing how it got those settings in the first place i can't tell what the best way to fix the problem is.. maybe someone else can....
     
  3. Slawka

    Slawka New Member

    Yes, I transferred the base from Centos.

    I could not find it on the web, I managed to change it through the database (server table, config field).
    user=apache -> www-data
    group=apache -> www-data
    nginx_user=www-data
    nginx_group=www-data
     
  4. Th0m

    Th0m ISPConfig Developer Staff Member ISPConfig Developer

    These settings should not be changed through the database as this won't trigger the change to the related files on your system. Undo this first. Then, you can change the settings through the UI: System -> Server Config -> server1.example.com -> Web
     
  5. Slawka

    Slawka New Member

    There is only for nginx and this is the Apache parameter
    The example in the attachment
     

    Attached Files:

Share This Page