Ubuntu 18.04 , some error when installing amvis

Discussion in 'Installation/Configuration' started by Peterwebdev, Jun 8, 2018.

  1. Peterwebdev

    Peterwebdev New Member

    Hi i am following
    https://www.howtoforge.com/tutorial/ubuntu-lts-minimal-server/2/
    i am installing it on a digital ocean vps

    after issuing this commend

    apt-get -y install amavisd-new spamassassin clamav clamav-daemon unzip bzip2 arj nomarch lzop cabextract apt-listchanges libnet-ldap-perl libauthen-sasl-perl clamav-docs daemon libio-string-perl libio-socket-ssl-perl libnet-ident-perl zip libnet-dns-perl postgrey

    i get this error log
    See "systemctl status amavis.service" and "journalctl -xe" for details.
    invoke-rc.d: initscript amavis, action "start" failed.
    ‚óŹ amavis.service - LSB: Starts amavisd-new mailfilter
    Loaded: loaded (/etc/init.d/amavis; generated)
    Active: failed (Result: exit-code) since Fri 2018-06-08 11:36:55 UTC; 28ms ag o
    Docs: man:systemd-sysv-generator(8)
    Process: 3671 ExecStart=/etc/init.d/amavis start (code=exited, status=1/FAILUR E)

    Jun 08 11:36:54 peterwebsolutions systemd[1]: Starting LSB: Starts amavisd-new m ailfilter...
    Jun 08 11:36:55 peterwebsolutions amavis[3671]: Starting amavisd: The value of variable $myhostname is "peterwebsolutions", but should have been
    Jun 08 11:36:55 peterwebsolutions amavis[3671]: a fully qualified domain name; perhaps uname(3) did not provide such.
    Jun 08 11:36:55 peterwebsolutions amavis[3671]: You must explicitly assign a F QDN of this host to variable $myhostname
    Jun 08 11:36:55 peterwebsolutions amavis[3671]: in /etc/amavis/conf.d/05-node_ id, or fix what uname(3) provides as a host's
    Jun 08 11:36:55 peterwebsolutions amavis[3671]: network name!
    Jun 08 11:36:55 peterwebsolutions amavis[3671]: (failed).
    Jun 08 11:36:55 peterwebsolutions systemd[1]: amavis.service: Control process ex ited, code=exited status=1
    Jun 08 11:36:55 peterwebsolutions systemd[1]: amavis.service: Failed with result 'exit-code'.
    Jun 08 11:36:55 peterwebsolutions systemd[1]: Failed to start LSB: Starts amavis d-new mailfilter.
    dpkg: error processing package amavisd-new (--configure):
    installed amavisd-new package post-installation script subprocess returned erro r exit status 1
    Setting up liblwp-protocol-https-perl (6.07-2) ...
    Setting up libwww-perl (6.31-1) ...
    Processing triggers for libc-bin (2.27-3ubuntu1) ...
    Processing triggers for ureadahead (0.100.0-20) ...
    Processing triggers for systemd (237-3ubuntu10) ...
    Errors were encountered while processing:
    amavisd-new
    E: Sub-process /usr/bin/dpkg returned an error code (1)


    i am not sure what do do now, i saw another person having this issue and he said that making a host name work so i went and create a host name but running the command again doesn't seem to install amavis? is there a command to start it again
     
    Last edited: Jun 8, 2018
  2. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    Those error messages say a Fully Qualified Domain Name FQDN is needed. peterwebsolutions is only the hostname, it needs the domain part also, ie. peterwebsolutions.domain.tld.
     
  3. Peterwebdev

    Peterwebdev New Member

    yeh i so another post and redid the host name but when i run the command again it says the stuff has already installed. im not sure what to do now to get amavid to run
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    The issue is not about installing amavis, it is about starting amavis. After you corrected the hostname, start amavis.
     
  5. Peterwebdev

    Peterwebdev New Member

    i am up to installing ftp part of the guide but when i got to
    nano /etc/fstab

    it shows

    LABEL=cloudimg-rootfs / ext4 defaults 0 0
    LABEL=UEFI /boot/efi vfat defaults 0 0
    instead of the one in the guide which is
    # /etc/fstab: static file system information.
    #
    # Use 'blkid' to print the universally unique identifier for a
    # device; this may be used with UUID= as a more robust way to name devices
    # that works even if disks are added and removed. See fstab(5).
    #
    # <file system> <mount point> <type> <options> <dump> <pass>
    /dev/mapper/server1--vg-root / ext4 errors=remount-ro,usrjquota=quota.user,grpjquota=quota.group,jqfmt=vfsv0 0 1
    /dev/mapper/server1--vg-swap_1 none swap sw 0 0
    /dev/fd0 /media/floppy0 auto rw,user,noauto,exec,utf8 0 0

    i am not sure how to add
    usrjquota=quota.user,grpjquota=quota.group,jqfmt=vfsv0
     
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    user and group quota is already enabled.
     
  7. Peterwebdev

    Peterwebdev New Member

    thanks i couldn't tell just from
    LABEL=cloudimg-rootfs / ext4 defaults 0 0
    LABEL=UEFI /boot/efi vfat defaults 0 0

    the log after that is not mind its what the guide shows, i guess ill skip the step afterwards if its already mounted

    weird this log means its not mounted right

    [email protected]:~# quotacheck -avugm
    quotacheck: Cannot find filesystem to check or filesystem not mounted with quota option.
     
  8. till

    till Super Moderator Staff Member ISPConfig Developer

    The info in the guide is for a normal Ubuntu install, you seem to use some kind of cloud server image thats's why it looks differently. When you read the lines of your existing fstab file, then you can see that the part "usrjquota=quota.user,grpjquota=quota.group,jqfmt=vfsv0" for the / file system is already there.
     
  9. Peterwebdev

    Peterwebdev New Member

    yeh i am using vps from digital ocean so there are some part that are hard to follow my existing fstab only shows
    LABEL=cloudimg-rootfs / ext4 defaults 0 0
    LABEL=UEFI /boot/efi vfat defaults 0 0

    "usrjquota=quota.user,grpjquota=quota.group,jqfmt=vfsv0" was the part where i posted from the guide
     
  10. till

    till Super Moderator Staff Member ISPConfig Developer

    ahh, ok. Then please change it in the way that you've shown in #5.
     

Share This Page