Ubuntu 18.04 Apache2 python error

Discussion in 'ISPConfig 3 Priority Support' started by concept21, Jun 9, 2019.

  1. concept21

    concept21 Member

    Hello,
    I am deploying ISPConfig 3.1.13p1 on Ubuntu 18.04. I find this error report in the file apache2/error.log
    How do I correct it? :oops:

    [:error] python_init: Python version mismatch, expected '2.7.6', found '2.7.15rc1'.
    [:error] python_init: Python executable found '/usr/bin/python'.
    [:error] python_init: Python path being used '/usr/lib/python2.7:/usr/lib/python2.7/plat-x86_64-linux-gnu:/usr/lib/python2.7/lib-tk:/usr/lib/python2.7/lib-old:/usr/lib/python2.7/lib-dynload'.
     
  2. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    Find out which application expects exactly Python version 2.7.6. It should not be any application that comes from Ubuntu 18.04 repositories, they should accept the 2.7.15~rc1-1ubuntu0.1 that is now in Ubuntu 18.04.
    Try
    Code:
    locate python_init
    apt-cache search python_init
    to find out where this python_init comes from.
    You wrote
    Is this a system you just installed? Was the Ubuntu 18.04 installed according to ISPConfig guide, i.e. there was nothing running there previously that now confuses the system?
     
  3. concept21

    concept21 Member

    Hello Taleman,
    Thanks for your un-official support. :D

    I think the cause is that - I have installed ppa.launchpad.net/ondrej/apache2/
    and it conflicts with the default Ubuntu 18.04 python.
    I am going to replace the apache2 mod_python with the one from official Ubuntu 18.04 repository. :)
     
  4. concept21

    concept21 Member

    Same thing happens!
    I think I have to compile a new apache2 python module. :(
     

Share This Page