Ubuntu 18.04.4 is using 1 CPU at all times - nothing listed in HTOP

Discussion in 'Desktop Operation' started by curiousadmin, Feb 11, 2020.

  1. curiousadmin

    curiousadmin New Member HowtoForge Supporter

    Hello Everyone,
    I'm running Desktop Ubuntu 18.04.4 LTS on my laptop HP zbook 15 G4 and my trouble is that the system (?) is using 1 CPU basically at all times even after fresh reboot and unfortunately nothing is listed in htop or top to debug this issue further:
    [​IMG]

    More details about the system:
    BIOS Information: Version: P70 Ver. 01.29
    Product Name: HP ZBook 15 G4
    Processor Information: Version: Intel(R) Core(TM) i7-7820HQ CPU @ 2.90GHz
    Note: CPU is 4 physical cores with HT.

    Any ideas how to debug this/find out what is using the resources?

    Thank you all for any input in advance.
     
  2. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    At the time of the screenshot, it is not using CPU barely at all. Use htop when the usage occurs to see which process is using CPU, and examine further from there.
    You have circled load figures on the screenshot, but ask about CPU. Read for example this (found using Internet Search Engines).
    https://www.howtogeek.com/194642/un...average-on-linux-and-other-unix-like-systems/
    I suspect slow disk on a laptop can not keep up with the fast CPU.
     
  3. curiousadmin

    curiousadmin New Member HowtoForge Supporter

    @Taleman Thank you for the followup however looking at that linked howtogeek article (unless I'm terribly misunderstanding the meaning of it) the load is referring only to CPU usage (CPU cores) - excluding of IO load, IO load can be measured using iotop (which shows no activity on read/write). My understanding is that the load average means load average over:
    load average over the last 1 minute: 1.74 ===> almost 2 CPU cores were used over last 1 minute
    load average over the last 5 minutes: 1.28 ===> slightly above 1 CPU cores were used over last 5 minutes
    load average over the last 15 minutes: 0.65 ===> about half of 1 CPU cores were used over last 15 minutes.
    (as per screenshot left to right)
    My system has SSD system drive (I did benchmark: read average 2.4GB/s, write average 425 MB/s --- 100 samples 10 MB each, access time 0.05 msec --- 1000 samples) and the system was not running anything except the terminal and Firefox with 1 window containing howtoforge.com
    Still for system being basically doing nothing especially the 1 minute average looks very high.
     
  4. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    That is not what it means.
    With 4 cores, loads under 2,8 are OK. Calculate this with 0,7 times number of cores.
    If you need to examine further where the load comes from, install dstat or similar tool and use the multiple monitoring options it has to find what is happening on that host.
     
  5. curiousadmin

    curiousadmin New Member HowtoForge Supporter

    Thank you @Taleman I will check dstat - wasn't aware of that tool.
     
  6. nhybgtvfr

    nhybgtvfr Active Member

Share This Page