Ubuntu 16.04 with ISPConfig 3 and multiple PHP version (5.6 and 7)

Discussion in 'Installation/Configuration' started by berbeque, Sep 6, 2017.

  1. berbeque

    berbeque New Member

    Hello,
    Default ISPConfig 3 instalation on Ubuntu with php 7.0.
    I've installed via apt-get the php5.6 packages and i configured additional PHP version in ISPconfig 3.

    I've configured a website with PHP 5.6 version and PHP-PHM module. in the webdirectory i added info.php to find out if the php version is changed from default (7.0).
    I get the error 500 now.

    Best regards,
    ADrian
     
  2. Jesse Norell

    Jesse Norell Well-Known Member

    check your webserver error log and/or your php-fpm log to see what's going on.
     
  3. ahrasis

    ahrasis Active Member

    So far that I know there is no apt-get for php5.6 in Ubuntu 16.04 unless you use some multiphp ppa. That is however not a problem unless you have not installed all the required php files for php5.6 or afterwards properly added the settings for it in additional php settings before you use it for your website.

    So I think you should first check if you already installed all the required files then check your additional php settings for php5.6.
     
    Last edited: Sep 9, 2017

Share This Page