Ubuntu 16.04 new mailserver installation can receive but cannot send

Discussion in 'Installation/Configuration' started by AliveonStage, May 5, 2017.

  1. AliveonStage

    AliveonStage New Member

    Hi Everyone,

    I'm new here since I've decided to host my own linux server and try to configure it myself.

    So I followed a turorial on digitalocean combined with thing I have found here on howtoforce, step by step and just to be sure I checked everything again.

    The problem I have is that I'm able to receive mails, but I cannot send...

    Before I begin I need to say that I did all my installations with
    Code:
    sudo
    in front of it. Perhaps this can be important to know?

    The error(s) I get when executing
    Code:
    sudo service postfix status
    are

    Code:
    May 05 11:34:05 mailserver01 postfix/smtpd[4657]: disconnect from unknown[80.82.65.204] ehlo=1 auth=0/1 rset=1 quit=1 commands=3/4
    May 05 11:34:53 mailserver01 postfix/qmgr[2906]: EA5792C0AAC: from=<info@mydomain.be>, size=682, nrcpt=1 (queue active)
    May 05 11:34:53 mailserver01 postfix/qmgr[2906]: 650172C0BF3: from=<info@mydomain.be>, size=405, nrcpt=1 (queue active)
    May 05 11:34:53 mailserver01 postfix/postdrop[4677]: fatal: /etc/postfix/dynamicmaps.cf: file open failed: Permission denied
    May 05 11:34:54 mailserver01 postfix/sendmail[4675]: warning: command "/usr/sbin/postdrop -r" exited with status 1
    May 05 11:34:54 mailserver01 postfix/sendmail[4675]: fatal: info@mydomain.be(1001): unable to execute /usr/sbin/postdrop -r: Success
    May 05 11:34:54 mailserver01 postfix/pipe[4670]: EA5792C0AAC: to=<myemail@telenet.be>, relay=spamassassin, delay=7187, delays=7186/0.01/0/1, dsn=4.3.0, status=deferred (temporary failure. Command output: postdrop: fatal: /etc/postfix
    May 05 11:35:23 mailserver01 postfix/smtp[4674]: connect to mx2.telenet-ops.be[195.130.132.9]:25: Connection timed out
    May 05 11:35:53 mailserver01 postfix/smtp[4674]: connect to mx1.telenet-ops.be[195.130.132.8]:25: Connection timed out
    May 05 11:35:53 mailserver01 postfix/smtp[4674]: 650172C0BF3: to=<myemail@telenet.be>, relay=none, delay=224704, delays=224644/0.01/60/0, dsn=4.4.1, status=deferred (connect to mx1.telenet-ops.be[195.130.132.8]:25: Connection timed out
    My rights on the folder and subfolders are
    Code:
    -rw-r----- 1 root root      153 Apr 28 12:51 dynamicmaps.cf
    -rw-r--r-- 1 root root     2674 May  5 09:05 main.cf
    -rw-r----- 1 root root     1388 Apr 28 14:23 main.cf.orig
    -rw-r----- 1 root root     6261 May  5 09:49 master.cf
    -rw-r----- 1 root postfix   142 May  1 13:07 mysql-virtual-alias-maps.cf
    -rw-r----- 1 root postfix   130 May  1 13:08 mysql-virtual-mailbox-domains.cf
    -rw-r----- 1 root postfix   129 May  1 13:07 mysql-virtual-mailbox-maps.cf
    -rw-r----- 1 root root    21233 Apr 13  2016 postfix-files
    -rwxr-x--- 1 root root     9344 Apr 13  2016 postfix-script
    -rwxr-x--- 1 root root    29446 Apr 13  2016 post-install
    drwxr-x--- 2 root root     4096 Apr 13  2016 sasl
    
    I really hope someone can help me with this!

    Thanks in advance
    Peter
     
  2. ahrasis

    ahrasis Active Member

    1. Check port 25 for sending mail, whether it is opened. Use a relay instead, if it is not opened.
    2. Check you postfix config in main.cf and master.cf files. I think your destination should not contain your mail domain.
     

Share This Page