Ubuntu 16.04 ISPConfig 3.1, Nginx, PHP7 and Owncloud 9.1.0

Discussion in 'ISPConfig 3 Priority Support' started by Tomnick, Sep 10, 2016.

  1. Tomnick

    Tomnick New Member HowtoForge Supporter

    Hello everbody,
    I am trying to set up Owncloud 9.1.0 at the above mentioned configuration. First I used that snipped from https://timmehosting.de/owncloud-hosting-auf-nginx. That turned out to be an error 503. Then I tried the Wordpress Snippet from https://timmehosting.de/wordpress-hosting-auf-nginx on experimental basis and that worked until everthing was set up and installed. Now I am getting the the php error :

    I am stucked right now. Does anybody have any idea what could be wrong or a snippet which is working for Owncloud 9.1? Thank you for some help
     
    CharlesDa likes this.
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Add a php file with contians the "phpinfo()" function to the website, then open it in a browser and check if the getenv function is disabled in php.
     
  3. Tomnick

    Tomnick New Member HowtoForge Supporter

    This is what owncloud says:
    Code:
    ;env[HOSTNAME] = $HOSTNAME
    ;env[PATH] = /usr/local/bin:/usr/bin:/bin
    ;env[TMP] = /tmp
    ;env[TMPDIR] = /tmp
    ;env[TEMP] = /tmp
    But this is already done by ISPConf in webXX.conf. So no need to change anything from my point of view and "printenv PATH" works. By the way I could no see anything on "phpinfo()" concerning getenv function
     

Share This Page