Ubuntu 16.04.2 LTS (Xenial Xerus) ISPConfig 3.1 - not receiving or sending email

Discussion in 'Installation/Configuration' started by Olhutch, Mar 6, 2017.

  1. Olhutch

    Olhutch New Member

    I'm getting in a bit of a mess, trying to tweek setting etc but I basically cant send and receive messages. I've rebuilt the server once, can get all the functionality apart from email. I've spend days trying to find the answer. looked at Reverse DNS, MX Toolbox report, brought a SSL Certificate, which I haven't installed as I cant receive emails on that domain. So if someone could help I would be very grateful.

    I've also disabled spam etc with the guide ispconfig3, how-to-disable-spamfilter-and-antivirus-functions-in-ispconfig-3/

    The only thing I can do is send emails from roundcube. I get a Add Security Exception when I try and send through thunderbird.

    Output from report
    ##### SERVER #####
    IP-address (as per hostname): IS-54900
    IP-address(es) (as per ifconfig): ***.***.***.***
    [WARN] ip addresses from hostname differ from ifconfig output. Please check your ip settings.
    [INFO] ISPConfig is installed.

    ##### ISPCONFIG #####
    ISPConfig version is 3.1dev


    ##### VERSION CHECK #####

    [INFO] php (cli) version is 7.0.15-0ubuntu***.***.***.***

    ##### PORT CHECK #####


    ##### MAIL SERVER CHECK #####


    ##### RUNNING SERVER PROCESSES #####

    [INFO] I found the following web server(s):
    Apache 2 (PID 1639)
    [INFO] I found the following mail server(s):
    Postfix (PID 8659)
    [INFO] I found the following pop3 server(s):
    Dovecot (PID 938)
    [INFO] I found the following imap server(s):
    Dovecot (PID 938)
    [INFO] I found the following ftp server(s):
    PureFTP (PID 1372)

    ##### LISTENING PORTS #####
    (only ()
    Local (Address)
    [localhost]:10025 (8659/master)
    [localhost]:10027 (8659/master)
    [anywhere]:587 (8659/master)
    [localhost]:11211 (902/memcached)
    [anywhere]:110 (938/dovecot)
    [anywhere]:143 (938/dovecot)
    [anywhere]:465 (8659/master)
    [anywhere]:21 (1372/pure-ftpd)
    ***.***.***.***:53 (870/named)
    [localhost]:53 (870/named)
    [anywhere]:22 (862/sshd)
    [anywhere]:25 (8659/master)
    [localhost]:953 (870/named)
    [anywhere]:6556 (1009/xinetd)
    [anywhere]:993 (938/dovecot)
    [anywhere]:995 (938/dovecot)
    ***.***.***.***:10023 (1186/postgrey.pid)
    [localhost]:10023 (1186/postgrey.pid)
    *:*:*:*::*:3306 (1210/mysqld)
    *:*:*:*::*:587 (8659/master)
    [localhost]10 (938/dovecot)
    [localhost]43 (938/dovecot)
    *:*:*:*::*:8080 (1639/apache2)
    *:*:*:*::*:80 (1639/apache2)
    *:*:*:*::*:465 (8659/master)
    *:*:*:*::*:8081 (1639/apache2)
    *:*:*:*::*:21 (1372/pure-ftpd)
    *:*:*:*::*:53 (870/named)
    *:*:*:*::*:22 (862/sshd)
    *:*:*:*::*:25 (8659/master)
    *:*:*:*::*:953 (870/named)
    *:*:*:*::*:443 (1639/apache2)
    *:*:*:*::*:993 (938/dovecot)
    *:*:*:*::*:995 (938/dovecot)
    *:*:*:*::*:10023 (1186/postgrey.pid)




    ##### IPTABLES #####
    Chain INPUT (policy ACCEPT)
    target prot opt source destination
    f2b-dovecot-pop3imap tcp -- [anywhere]/0 [anywhere]/0 multiport dports
    110,995,143,993
    f2b-pureftpd tcp -- [anywhere]/0 [anywhere]/0 multiport dports 21
    f2b-postfix-sasl tcp -- [anywhere]/0 [anywhere]/0 multiport dports 25
    f2b-sshd tcp -- [anywhere]/0 [anywhere]/0 multiport dports 22

    Chain FORWARD (policy ACCEPT)
    target prot opt source destination

    Chain OUTPUT (policy ACCEPT)
    target prot opt source destination

    Chain f2b-dovecot-pop3imap (1 references)
    target prot opt source destination
    RETURN all -- [anywhere]/0 [anywhere]/0

    Chain f2b-postfix-sasl (1 references)
    target prot opt source destination
    RETURN all -- [anywhere]/0 [anywhere]/0

    Chain f2b-pureftpd (1 references)
    target prot opt source destination
    RETURN all -- [anywhere]/0 [anywhere]/0

    Chain f2b-sshd (1 references)
    target prot opt source destination
    RETURN all -- [anywhere]/0 [anywhere]/0



    You have new mail in /var/mail/root

    Mail.log info
    Mar 6 02:03:11 IS-54900 postfix/qmgr[8661]: 9633D721DFE: from=<email.add @ superpremium.co.uk>, size=691, nrcpt=2 (queue active)
    Mar 6 02:03:11 IS-54900 postfix/smtp[10153]: connect to 127.0.0.1[127.0.0.1]:10026: Connection refused
    Mar 6 02:03:11 IS-54900 postfix/smtp[10154]: connect to 127.0.0.1[127.0.0.1]:10024: Connection refused
    Mar 6 02:03:11 IS-54900 postfix/smtp[10153]: A6748721DCB: to=<email.add @ bowmeows.co.uk>, relay=none, delay=8652, delays=8652/0.01/0/0, dsn=4.4.1, status=def$
    Mar 6 02:03:11 IS-54900 postfix/smtp[10154]: 4DFF3721D2C: to=<root @ superpremium.co.uk>, orig_to=<root>, relay=none, delay=16990, delays=16990/0.02/0/0, dsn=4.4.1,$
    Mar 6 02:03:11 IS-54900 postfix/smtp[10153]: A6748721DCB: to=<emailadd @ googlemail.com>, relay=none, delay=8652, delays=8652/0.01/0/0, dsn=4.4.1, status=defe$
    Mar 6 02:03:11 IS-54900 postfix/smtp[10154]: connect to 127.0.0.1[127.0.0.1]:10024: Connection refused
    Mar 6 02:03:11 IS-54900 postfix/smtp[10153]: connect to 127.0.0.1[127.0.0.1]:10024: Connection refused
    Mar 6 02:03:11 IS-54900 postfix/smtp[10154]: 8FE78721D00: to=<root @ superpremium.co.uk>, orig_to=<root>, relay=none, delay=20350, delays=20350/0.04/0/0, dsn=4.4.1,$
    Mar 6 02:03:11 IS-54900 postfix/smtp[10153]: 2CDD9721C37: to=<email.add @ superpremium.co.uk>, relay=none, delay=1143, delays=1143/0.04/0/0, dsn=4.4.1, status$
    Mar 6 02:03:11 IS-54900 postfix/smtp[10153]: connect to 127.0.0.1[127.0.0.1]:10026: Connection refused
    Mar 6 02:03:11 IS-54900 postfix/smtp[10154]: connect to 127.0.0.1[127.0.0.1]:10026: Connection refused
    Mar 6 02:03:11 IS-54900 postfix/smtp[10153]: 6F6B3721DFF: to=<emailadd @ googlemail.com>, relay=none, delay=926, delays=926/0.05/0/0, dsn=4.4.1, status=deferr$
    Mar 6 02:03:11 IS-54900 postfix/smtp[10154]: F235E721DF9: to=<emailadd @ googlemail.com>, relay=none, delay=2122, delays=2122/0.05/0/0, dsn=4.4.1, status=defe$
    Mar 6 02:03:11 IS-54900 postfix/smtp[10154]: F235E721DF9: to=<emailadd @ googlemail.com>, relay=none, delay=2122, delays=2122/0.05/0/0, dsn=4.4.1, status=defe$
    Mar 6 02:03:11 IS-54900 postfix/error[10158]: 6C133721D8B: to=<root @ superpremium.co.uk>, orig_to=<root>, relay=none, delay=13030, delays=13030/0.06/0/0.01, dsn=4.$
    Mar 6 02:03:11 IS-54900 postfix/smtp[10154]: connect to 127.0.0.1[127.0.0.1]:10026: Connection refused
    Mar 6 02:03:11 IS-54900 postfix/smtp[10153]: 6F6B3721DFF: to=<emailadd @ googlemail.com>, relay=none, delay=926, delays=926/0.05/0/0, dsn=4.4.1, status=deferr$
    Mar 6 02:03:11 IS-54900 postfix/error[10159]: 5182A721CF1: to=<root @ superpremium.co.uk>, orig_to=<root>, relay=none, delay=20950, delays=20950/0.06/0/0.01, dsn=4.$
     
  2. florian030

    florian030 ISPConfig Developer ISPConfig Developer

    start amavis
     
  3. Olhutch

    Olhutch New Member

    Thanks for your help, think its sorted a bit of this although still not receiving emails.
    Hi tried starting the service,
    root@IS-54900:~# service amavis start
    Job for amavis.service failed because the control process exited with error code. See "systemctl status amavis.service" and "journalctl -xe" for details.

    ‚óŹ amavis.service - LSB: Starts amavisd-new mailfilter
    Loaded: loaded (/etc/init.d/amavis; bad; vendor preset: enabled)
    Active: failed (Result: exit-code) since Mon 2017-03-06 15:46:47 GMT; 1min 58s ago
    Docs: man:systemd-sysv-generator(8)
    Process: 17099 ExecStart=/etc/init.d/amavis start (code=exited, status=1/FAILURE)

    /etc/init.d/amavis
    Mar 06 15:46:47 IS-54900 amavis[17099]: The value of variable $myhostname is "", but should have been
    Mar 06 15:46:47 IS-54900 amavis[17099]: a fully qualified domain name; perhaps uname(3) did not provide such.
    Mar 06 15:46:47 IS-54900 amavis[17099]: You must explicitly assign a FQDN of this host to variable $myhostname
    Mar 06 15:46:47 IS-54900 amavis[17099]: in /etc/amavis/conf.d/05-node_id, or fix what uname(3) provides as a host's
    Mar 06 15:46:47 IS-54900 amavis[17099]: network name!
    Mar 06 15:46:47 IS-54900 amavis[17099]: (failed).
    Mar 06 15:46:47 IS-54900 systemd[1]: amavis.service: Control process exited, code=exited status=1
    Mar 06 15:46:47 IS-54900 systemd[1]: Failed to start LSB: Starts amavisd-new mailfilter.
    Mar 06 15:46:47 IS-54900 systemd[1]: amavis.service: Unit entered failed state.
    Mar 06 15:46:47 IS-54900 systemd[1]: amavis.service: Failed with result 'exit-code'.

    So ive edited the file /etc/amavis/conf.d/05-node_id as described above and added the line
    $myhostname = "mail.mydomain.co.uk";

    then Started amavis, no errors so it looks like it has started I have previously to this commented out
    #content_filter = amavis:[127.0.0.1]:10024
    #receive_override_options = no_address_mappings
    on main.cf

    From my mail.log now

    Mar 6 16:18:07 IS-54900 postfix/smtpd[19360]: E21E2721BF6: client=localhost[127.0.0.1]
    Mar 6 16:18:07 IS-54900 postfix/cleanup[19338]: E21E2721BF6: message-id=<20170306161801.74A2E721C22 @ mydomain.co.uk>
    Mar 6 16:18:07 IS-54900 postfix/qmgr[19304]: E21E2721BF6: from=<root@ mydomain.co.uk>, size=1784, nrcpt=1 (queue active)
    Mar 6 16:18:07 IS-54900 postfix/smtpd[19360]: disconnect from localhost[127.0.0.1] ehlo=1 mail=6 rcpt=6 data=6 noop=1 quit=1 commands=21
    Mar 6 16:18:07 IS-54900 postfix/trivial-rewrite[19340]: warning: do not list domain mydomain.co.uk in BOTH mydestination and virtual_mailbox_domains
    Mar 6 16:18:07 IS-54900 amavis[18785]: (18785-07) Passed CLEAN {RelayedInternal}, LOCAL [127.0.0.1] <root @ mydomain.co.uk> -> <root @ mydomain.co.uk>, Message-ID: <20170306161801.74A2E721C22@ mydomain.co.uk>, mail_id: yHbYo_pv2xM2, Hits: 0.001, size: 1315, queued_as: E21E2721BF6, 6456 ms
    Mar 6 16:18:07 IS-54900 postfix/local[19345]: E21E2721BF6: to=<root@ mydomain.co.uk>, relay=local, delay=0.02, delays=0.01/0/0/0.01, dsn=2.0.0, status=sent (delivered to mailbox)
    Mar 6 16:18:07 IS-54900 postfix/smtp[19309]: 74A2E721C22: to=<root@ mydomain.co.uk>, orig_to=<root>, relay=127.0.0.1[127.0.0.1]:10024, delay=6.5, delays=0.02/0/0/6.5, dsn=2.0.0, status=sent (250 2.0.0 from MTA(smtp:[127.0.0.1]:10025): 250 2.0.0 Ok: queued as E21E2721BF6)
    Mar 6 16:18:07 IS-54900 postfix/qmgr[19304]: E21E2721BF6: removed
    Mar 6 16:18:07 IS-54900 postfix/qmgr[19304]: 74A2E721C22: removed

    Thought I'd mention when I send a message to myself in roundcube it also does not deliver although it leaves as normal
     
  4. Olhutch

    Olhutch New Member

    Thanks for your help really grateful, after your help solving that 1st problem I've checked the maillog again I've and the line:

    warning: do not list domain mydomain.co.uk in BOTH mydestination and virtual_mailbox_domains

    followed the www . howtoforge . com /community/threads/maildelivery-unknown-user.45369/ which has sorted my problem, I think.

    really pleased thank you :) Just need to sort out the SSL certificate now!
     

Share This Page