UBUNTU 16.04.1 LTS

Discussion in 'Installation/Configuration' started by edi00, Aug 17, 2016.

  1. edi00

    edi00 Member

    Currently I have Ubuntu 14.04.5 LTS (GNU/Linux 3.13.0-45-generic x86_64) and ISPConfig Version:
    I am itching to upgrade my UBUNTU to 16.04.1 LTS
    FAQ: What incompatibility can I find with ISPConfig Version:
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    ISPConfig 3.0.5.x does not run on PHP 7 and Ubuntu 16.04 uses PHP 7, so you will have to update to ISPConfig 3.1rc2 after upgrading ubuntu.
  3. f1vnc

    f1vnc New Member


    I've got the same problem. I moved to Ubuntu 16.04 and ispconfig is broken.

    If I upgrade, will it mess up my database or any other configs?

    Many Thanks
  4. florian030

    florian030 ISPConfig Developer ISPConfig Developer

    The update will not mess anything (as long as you did not change the configs by yourself). Upgrade ro rc2 and choose reconfigure services during the update.
  5. f1vnc

    f1vnc New Member


    Thanks for replying.

    I ran the update (except I had to use php5.6 -q update.php because the update scripts refer to mysql_connect() which has been removed from php7).

    I answered "no" to the changes.

    Now, when I try, I get ...

    .php-fcgi-starter: 6: exec: /usr/bin/php-cgi: not found
    [Sat Aug 20 17:22:51.931088 2016] [fcgid:warn] [pid 15310] (104)Connection reset by peer: [client] mod_fcgid: error reading data from FastCGI server
    [Sat Aug 20 17:22:51.931150 2016] [core:error] [pid 15310] [client] End of script output before headers: index.php
    ... in the apache error log.
  6. f1vnc

    f1vnc New Member


    Sorry, didn't see reconfig services, so I did it again and got this ...

    >> Update 
    Operating System: Debian or compatible, unknown version.
    This application will update ISPConfig 3 on your server.
    mysql: [Warning] Using a password on the command line interface can be insecure.
    mysqldump: [Warning] Using a password on the command line interface can be insecure.
    PHP Deprecated:  mysql_connect(): The mysql extension is deprecated and will be removed in the future: use mysqli or PDO instead in /tmp/ispconfig3_install/install/lib/mysql.lib.php on line 78
    Starting incremental database update.
    Reconfigure Permissions in master database? (yes,no) [no]: no
    Reconfigure Services? (yes,no) [yes]: yes
    Configuring Postfix
    Configuring Jailkit
    Configuring Dovecot
    Configuring Spamassassin
    Configuring Amavisd
    Configuring Getmail
    Configuring Pureftpd
    Configuring BIND
    Configuring Apache
    Configuring vlogger
    Configuring Apps vhost
    Configuring Database
    Configuring Firewall
    Updating ISPConfig
    ISPConfig Port [8080]:
    Create new ISPConfig SSL certificate (yes,no) [no]: no
    Reconfigure Crontab? (yes,no) [yes]: no
    Restarting services ...
    Restarting mysql (via systemctl): mysql.service.
    Restarting postfix (via systemctl): postfix.service.
    Restarting amavis (via systemctl): amavis.service.
    Restarting clamav-daemon (via systemctl): clamav-daemon.service.
    Restarting courier-authdaemon (via systemctl): courier-authdaemon.service.
    Job for dovecot.service failed because the control process exited with error code. See "systemctl status dovecot.service" and "journalctl -xe" for details.
    Restarting dovecot (via systemctl): dovecot.service failed!
    Job for apache2.service failed because the control process exited with error code. See "systemctl status apache2.service" and "journalctl -xe" for details.
    Restarting apache2 (via systemctl): apache2.service failed!
    Restarting pure-ftpd-mysql (via systemctl): pure-ftpd-mysql.service.
    * Stopping domain name service... bind9
    waiting for pid 3073 to die
    * Starting domain name service... bind9
    Now mail and and my web server are down!
  7. florian030

    florian030 ISPConfig Developer ISPConfig Developer

    with php7 use ispconfig 3.1 and not
  8. f1vnc

    f1vnc New Member

    After several hours of effort I got things going again. Problems with references to non-existent modules and ssl key settings.

    As I don't really need ipsconfig, I also managed to disengage from it completely.

    Thanks anyway.
  9. edi00

    edi00 Member

    So let me make this clear Florian:
    When I update UBUNTU itself -- everything will work on the server.
    Than I update ISPConfig to 3.1rc2 and;
    substitute (my old) /usr/local/ispconfig/server/conf/vhost.conf.master and;
    I will open /etc/apache2/sites-enabled and delete all 100-******.vhost and;
    I will open ISPConfig and Resync all and;
    it will work?
    I do not have to be concern with PHP 7?
  10. florian030

    florian030 ISPConfig Developer ISPConfig Developer

    As long as your websites will work with php 7, this should word. You don't need to change any configs by yourself. Update ispconfig with reconfigure services and resync the websites afterwards.
  11. edi00

    edi00 Member

    FAQ1: If I upgrade ISPconfig to 3.1rc2, and keep my UBUNTU at current 14.04.5 LTS, and make no changes to any configs, will ISPconfig 3.1rc2 work with my current UBUNTU, do I have to Resync anyway.
    FAQ2: My websites are not build on PHP but Perl. Will it work?

Share This Page