Ubuntu 14.04 ->16.04 and IPSC 3.1 upgrade?

Discussion in 'General' started by somnium, Sep 9, 2016.

  1. somnium

    somnium New Member

    i want to upgrade my multiserver ispconfig environment from 14.04 to 16.04. My servers are:
    ispconfig (master server, only for ispconfig webgui)
    web1 (Apache Webserver)
    web2 (NginX Webserevr)
    ns1+ns2 (Nameservers)
    db (Databases)
    mail (Mailserver)

    I don't want to upgrade the webservers because of PHP7 and other deep impacts. But is it possible to upgrade the other servers and do an upgrade to ispconfig to 3.1 on all servers?

    anyone with experience?
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Yes, that's possible.
    somnium likes this.
  3. somnium

    somnium New Member

    Sorry for the delay. An other question: is it possible to upgrade only some of the multiserver environment to 3.1? I would like to start only with one nameserver and one webserver. i'm afraid touching my production webserver with a hundred of websites on it.
    and one more question: i've installed the dkim-patch from Florian and the dnssec/tlsa-patch. Has someone some experiences with the upgrade of a patched ispc 3.0?
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    No, all servers in a multiserver setup must run the same version.
    somnium likes this.
  5. florian030

    florian030 ISPConfig Developer ISPConfig Developer

    There are no dkim-differences between the patch and 3.1. You can not use different ispconfig-versions in a multiserver-setup.
    somnium likes this.

Share This Page