Ubuntu 13.04 APS Problem

Discussion in 'Installation/Configuration' started by MikeMcNuke, May 2, 2013.

  1. MikeMcNuke

    MikeMcNuke New Member


    I installed ISPConfig with the help of this http://www.howtoforge.com/perfect-server-ubuntu-13.04-apache2-bind-dovecot-ispconfig-3 tutorial.

    One problem left: APS packages won't update or get populated at all.

    Error code for every package available:

    [INTERFACE]: APS crawler: Cannot read metadata from Xaraya-1.1.4-3.app.zip
    Logfiles are not very helpful. 3 SimpleXML Warnings from PHP in lib/classes/aps_crawler.inc.php in Line 275:

    $sxe = new SimpleXMLElement($xml);
    But the XML gets generated.

    The crawler is able to make directories in interface/web/sites/aps_meta_packages and places one file in every directory:

    Example Directoryname: Zen Cart-1.5.1-10.app.zip
    Filename in this directory: PKG_URL

    Content of PKG_URL:
    But no packages get downloaded, all MySQL Tables for aps_*, except settings, are empty. Debug log from ISPConfig doesn't deliver any further information. php5-curl and cURL are installed.

    But something is missing! Can anyone help me?

    Mike McNuke
    Last edited: May 2, 2013
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Do you have a router or firewall in front of the server which might block access to apsstandard.org so that the packages cant be downloaded?
  3. MikeMcNuke

    MikeMcNuke New Member


    Firewall is installed on server, ufw with iptables. Server sits in some datahouse.

    Also I tried a curl on apsstandards.org and apscatalog.com via ssh on the server.

    curl apscatalog.com
    curl apsstandard.org
    and the data gets delivered to the shell.
  4. MikeMcNuke

    MikeMcNuke New Member

    Just turned off ufw and flushed iptables. But no difference.
  5. MikeMcNuke

    MikeMcNuke New Member

    Just digged a little deeper into aps_crawler.inc.php:

    In the function public function startCrawler() it's able to fill the $apps_to_dl[] array with the correct information about Files.

    But after this part of the function:

                    // For memory reasons, unset the current vendor and his apps
    it seems to stop doing anything. Strange. memorylimit is 512MB, so this should be sufficient. How can I trace the problem further???
  6. MikeMcNuke

    MikeMcNuke New Member

    Just did an update on a Ubuntu 12.10 Server from ISPConfig 3.0.5-rc2 to . APS did work on rc2, but now the same problem. Damn. There must be some config problem.
  7. frank81ita

    frank81ita New Member

    APS Problem

    I'm having the same problem, but it's on Debian instead on Ubuntu (there aren't some differences).
    Did you find a solution?
    I tried to disable quota and some other stuffs, but I can't find a solution?
    All downloads are working without any problem.
    Best Regards
  8. MikeMcNuke

    MikeMcNuke New Member

    Until now no update on the problem.

    Will install 2vms with ubuntu. One with older ispconfig one with new ispconfig. Perhaps I can find the error...
  9. MikeMcNuke

    MikeMcNuke New Member

    Problem fixed. I got back to my install files from ispconfig and ran the update script.

    php -q update.php

    Back in the frontend the APS packages get nowupdated and listed. But I don't know why. Did a backup of /etc before the update and compared all configs. No difference.

    My Testinstalls on 2 VMs are also fully working.

    Bad Hair... *hhmmm* Hosting Day???

Share This Page