Ubuntu 12.10 Perfect Server PHP Installation Problems

Discussion in 'Installation/Configuration' started by monomythmacabre, Nov 9, 2012.

  1. monomythmacabre

    monomythmacabre New Member

    I'm having a little bit of a problem with the 12.10 Ubuntu Perfect Server Install. In step 14.3 Additional PHP Versions I find myself without anything located in /opt/php-5.3.18/ so am unable to copy over some of the required files or continue on with the rest of that section.

    Any ideas why this might be?
     
  2. falko

    falko Super Moderator ISPConfig Developer

    Do you get any errors during the build process?
     
  3. NewAmericanClassic

    NewAmericanClassic New Member

  4. falko

    falko Super Moderator ISPConfig Developer

    Any other errors before this one?
     
  5. NewAmericanClassic

    NewAmericanClassic New Member

    I followed the guide to an exact point on a fresh install.
     
  6. NewAmericanClassic

    NewAmericanClassic New Member

    I think I found the issue, it is located on

    the php configure,

    configure: error: Cannot find libmysqlclient under /usr.
    Note that the MySQL client library is not bundled anymore!
     
  7. NewAmericanClassic

    NewAmericanClassic New Member

    I was able to fix the error by changing the configure to

    Code:
    ./configure \
    --prefix=/opt/php-5.3.18 \
    --with-pdo-pgsql \
    --with-zlib-dir \
    --with-freetype-dir \
    --enable-fpm \
    --enable-mbstring \
    --with-libxml-dir=/usr \
    --enable-soap \
    --enable-calendar \
    --with-curl --with-mcrypt \
    --with-zlib \
    --with-gd \
    --with-pgsql \
    --disable-rpath \
    --enable-inline-optimization \
    --with-bz2 \
    --with-zlib \
    --enable-sockets \
    --enable-sysvsem \
    --enable-sysvshm \
    --enable-pcntl \
    --enable-mbregex \
    --with-mhash \
    --enable-zip \
    --with-pcre-regex \
    --with-mysql \
    --with-pdo-mysql \
    --with-mysqli \
    --with-jpeg-dir=/usr \
    --with-png-dir=/usr \
    --enable-gd-native-ttf \
    --with-openssl \
    --with-fpm-user=www-data \
    --with-fpm-group=www-data \
    --with-libdir=/lib/i386-linux-gnu
    I however now receive

    sudo: insserv: command not found

    after the "insserv php-5.3.18-fpm" command
     
  8. NewAmericanClassic

    NewAmericanClassic New Member

    seems to be fixed by this thread

    http://www.howtoforge.com/forums/showthread.php?t=59242

    however it seems sloppy, and now I run into the issue after I enter "Full qualified hostname (FQDN)" while under sudo php -q install.php, and it says "No PHP MySQL functions available. Please ensure that the PHP MySQL module is loaded"
     
  9. NewAmericanClassic

    NewAmericanClassic New Member

  10. NewAmericanClassic

    NewAmericanClassic New Member

  11. falko

    falko Super Moderator ISPConfig Developer

    Are you sure you followed the guide to the letter?

    Instead of insserv, you can use
    Code:
    update-rc.d php-5.3.18-fpm defaults
     
  12. NewAmericanClassic

    NewAmericanClassic New Member

    Yes, I did a clean install of 12.10 386 prior to the config paper. I did try that already. I am however using ssh (sudo) and nano instead of local and vi.
     
  13. NewAmericanClassic

    NewAmericanClassic New Member

    If only you had an install/error check script (which I would pay for).
     
  14. togo

    togo New Member

    I almost ran out of hair trying to figure this out. Eventually I just changed the "--with-mysql" line with "--with-mysql-client" and it worked!
     
  15. falko

    falko Super Moderator ISPConfig Developer

Share This Page