Ubuntu 12.10 DNS loop problems

Discussion in 'HOWTO-Related Questions' started by daseagle, Jan 15, 2013.

  1. daseagle

    daseagle New Member

    Hello!

    I recently tried an Ubuntu 12.10. It was checked against falko's perfect server tutorial, install process was pretty much the same.

    Enviroment:

    Server is located behind a router, internal ip 192.168.111.251. Router has all the relevant ports (ftp, ssh, mail, dns, web, https) forwarded to this ip.

    Problem:

    I created the nameservers in ispconfig via the dns config wizard and checked their creation manually in /etc/bind. Then from my registrar, I pointed the example.com domain to the newly created nameservers. After waiting for some time for DNS to propagate, I realised something was off - basically I think I'm facing a circular reference problem.

    My dns records look like this:

    /etc/bind/pri.example.com [BM--] 0 L:[ 1+ 0 1/ 17] *(0 / 698b) 0036 0x024
    $TTL 3600
    @ IN SOA ns1.example.com. daseagle.gmail.com. (
    2013011101 ; serial, todays date + todays serial #
    7200 ; refresh, seconds
    540 ; retry, seconds
    604800 ; expire, seconds
    86400 ) ; minimum, seconds
    ;


    example.com. 3600 A 82.208.133.99
    example.com. 3600 MX 10 mail.example.com.
    example.com. 3600 NS ns1.example.com.
    www 3600 A 82.208.XXX.XX
    mail 3600 A 82.208.XXX.XX

    ---

    Help? I really don't know how to get around it.
     
  2. daseagle

    daseagle New Member

    Problem is not with DNS glue as it might look at first glance.

    Damn server won't even resolve localhost via nslookup.
     
  3. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    What's in /etc/resolv.conf and /etc/hosts?
     
  4. daseagle

    daseagle New Member

    Thanks Falko for answering, unfortunately I was pressed for time and I had to revert to a 6.3 Centos. Heavier on the hardware but couldn't be helped.

    I switched to a Centos 6.3, got it working after a bit of tinkering.

    Question: I see that as of now, my server allows recursive queries. Can I change that in \etc\named.conf ? I see there a "recursion yes" part...
     
    Last edited: Jan 16, 2013
  5. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    1) The format is correct, but there are two records missing. If you use ns records in a zone that are subdomains of the same zone, then you have to add A-records for these subdomains in the zone. Its the same issue with your first post, so ubuntu was not a problem here, there were just 2 records missing.

    A ns xx.xxx.xxx.xx 0
    A ns2 xx.xxx.xxx.xx 0

    Btw, the bind error that the zone was skipped due to errors must have been reported in /var/log/syslog on your Ubuntu server.

    2) You dont have to run your own dns server.

    3) Reason explained in 1).
     
  6. daseagle

    daseagle New Member

    Many thanks for the reply.

    Works perfectly now.

    So final lesson: if I have ns.example.com for example.com, then I must also have A records for ns.example.com.

    So noted.


    Btw, I skipped the ubuntu not because of the dns, I knew it was something I missed, but because of the issues it had with my 4x scsi controllers.

    Problem solved!
     

Share This Page