[Ubuntu 12.04] DNS problem

Discussion in 'Installation/Configuration' started by we_are_borg, Apr 30, 2012.

  1. we_are_borg

    we_are_borg New Member

    I have a DNS issue at this point i am using ISPConfig for internal use only so to the outside world its not important that they can contact me.

    Situation is as follows i made an domain including DNS zones in ISPConfig:
    Code:
    A	mail	192.168.1.123	0	
    A	vertaal.loc.	192.168.1.123	0	
    A	www	192.168.1.123	0	
    MX	vertaal.loc.	mail.vertaal.loc.	10	
    NS	vertaal.loc.	ns1.vertaal.loc.	0	
    NS	vertaal.loc.	ns2.vertaal.loc.	0	
    
    When i do a DIG i get the following:
    Code:
    ; <<>> DiG 9.8.1-P1 <<>> vertaal.loc
    ;; global options: +cmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: SERVFAIL, id: 57623
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 0, ADDITIONAL: 0
    
    ;; QUESTION SECTION:
    ;vertaal.loc.INA
    
    ;; Query time: 1 msec
    ;; SERVER: 127.0.0.1#53(127.0.0.1)
    ;; WHEN: Mon Apr 30 11:29:02 2012
    ;; MSG SIZE  rcvd: 29
    
    My /etc/network/interfaces is as follows:
    Code:
    # This file describes the network interfaces available on your system
    # and how to activate them. For more information, see interfaces(5).
    
    # The loopback network interface
    auto lo
    iface lo inet loopback
    
    # The primary network interface
    auto eth0
    iface eth0 inet static
            address 192.168.1.123
            netmask 255.255.255.0
            network 192.168.1.0
            broadcast 192.168.1.255
            gateway 192.168.1.1
            # dns-* options are implemented by the resolvconf package, if installed
            dns-nameservers 127.0.0.1 192.168.1.123 192.168.1.1
            dns-search webhosting.loc
    
    The server is installed using http://www.howtoforge.com/perfect-server-ubuntu-12.04-lts-apache2-bind-dovecot-ispconfig-3 as manual every command was executed in that howto.

    I hope that some one can help me.
     
  2. falko

    falko Super Moderator

    Does
    Code:
    dig @localhost vertaal.loc
    work? What are the outputs of
    Code:
    netstat -tap
    and
    Code:
    netstat -uap
    ?
     
  3. we_are_borg

    we_are_borg New Member

    Thanks Falko here under the outputs of the commands. It's strange but with ISPConfig i have always got problems with the DNS while when i use virtualmin it just works straight away.

    DIG @Localhost
    Code:
    ; <<>> DiG 9.8.1-P1 <<>> @localhost vertaal.loc
    ; (1 server found)
    ;; global options: +cmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: SERVFAIL, id: 37483
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 0, ADDITIONAL: 0
    
    ;; QUESTION SECTION:
    ;vertaal.loc.INA
    
    ;; Query time: 2 msec
    ;; SERVER: 127.0.0.1#53(127.0.0.1)
    ;; WHEN: Tue May  1 17:02:13 2012
    ;; MSG SIZE  rcvd: 29
    
    netstat -tap
    Code:
    Active Internet connections (servers and established)
    Proto Recv-Q Send-Q Local Address           Foreign Address         State       PID/Program name
    tcp        0      0 localhost.localdo:10025 *:*                     LISTEN      1887/master
    tcp        0      0 *:mysql                 *:*                     LISTEN      927/mysqld
    tcp        0      0 *:pop3                  *:*                     LISTEN      906/dovecot
    tcp        0      0 *:imap2                 *:*                     LISTEN      906/dovecot
    tcp        0      0 *:http-alt              *:*                     LISTEN      1966/apache2
    tcp        0      0 *:http                  *:*                     LISTEN      1966/apache2
    tcp        0      0 *:tproxy                *:*                     LISTEN      1966/apache2
    tcp        0      0 *:ftp                   *:*                     LISTEN      1907/pure-ftpd (SER
    tcp        0      0 server1.webhosti:domain *:*                     LISTEN      946/named
    tcp        0      0 localhost.locald:domain *:*                     LISTEN      946/named
    tcp        0      0 *:ssh                   *:*                     LISTEN      799/sshd
    tcp        0      0 *:smtp                  *:*                     LISTEN      1887/master
    tcp        0      0 localhost.localdoma:953 *:*                     LISTEN      946/named
    tcp        0      0 *:https                 *:*                     LISTEN      1966/apache2
    tcp        0      0 *:imaps                 *:*                     LISTEN      906/dovecot
    tcp        0      0 *:pop3s                 *:*                     LISTEN      906/dovecot
    tcp        0      0 localhost.localdom:9000 *:*                     LISTEN      1785/php-fpm.conf)
    tcp        0      0 localhost.localdo:10024 *:*                     LISTEN      1019/amavisd (maste
    tcp        0    404 server1.webhosting.:ssh 192.168.1.200:52185     ESTABLISHED 2316/0
    tcp6       0      0 [::]:pop3               [::]:*                  LISTEN      906/dovecot
    tcp6       0      0 [::]:imap2              [::]:*                  LISTEN      906/dovecot
    tcp6       0      0 [::]:ftp                [::]:*                  LISTEN      1907/pure-ftpd (SER
    tcp6       0      0 [::]:domain             [::]:*                  LISTEN      946/named
    tcp6       0      0 [::]:ssh                [::]:*                  LISTEN      799/sshd
    tcp6       0      0 [::]:smtp               [::]:*                  LISTEN      1887/master
    tcp6       0      0 ip6-localhost:953       [::]:*                  LISTEN      946/named
    tcp6       0      0 [::]:imaps              [::]:*                  LISTEN      906/dovecot
    tcp6       0      0 [::]:pop3s              [::]:*                  LISTEN      906/dovecot
    
    netstat -uap
    Code:
    Active Internet connections (servers and established)
    Proto Recv-Q Send-Q Local Address           Foreign Address         State       PID/Program name
    udp        0      0 server1.webhosti:domain *:*                                 946/named
    udp        0      0 localhost.locald:domain *:*                                 946/named
    udp        0      0 server1.webhosting.:ntp *:*                                 802/ntpd
    udp        0      0 localhost.localdoma:ntp *:*                                 802/ntpd
    udp        0      0 *:ntp                   *:*                                 802/ntpd
    udp6       0      0 [::]:domain             [::]:*                              946/named
    udp6       0      0 fe80::20c:29ff:fe72:ntp [::]:*                              802/ntpd
    udp6       0      0 ip6-localhost:ntp       [::]:*                              802/ntpd
    udp6       0      0 [::]:ntp                [::]:*                              802/ntpd
    
     
  4. pititis

    pititis Member

    You need an A records for ns1 and ns2

    Cheers
     
  5. we_are_borg

    we_are_borg New Member

    Thanks that did it.

    Why did ISPConfig not do it for me i used the wizard to make the zone.
     
  6. falko

    falko Super Moderator

    Because usually you use nameservers from another zone (i.e., the A records for the nameservers are defined in that other zone). In your case the nameservers are from the same zone.
     
  7. we_are_borg

    we_are_borg New Member

    Maybe something that ISPConfig can take in account or give an explicit warning.
     

Share This Page