Ubuntu 12.04 can't send emails

Discussion in 'General' started by razor7, Sep 6, 2012.

  1. razor7

    razor7 Member

    Hi, just finished installing ISP Config 3 with perfect server guide on Ubuntu server 12.04 and created a domain and a email mailbox for that domain.

    I can receive emails from that email box and squirrelmail, from gmail and my google apps accounts, but when replying, the email get sent, but can't receive it on the destination mailboxes.

    Where can I start looking?

    Thanks a lot!
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Please post the errors that you get in the mail.log file.
  3. razor7

    razor7 Member

    Well, it's completely empty!, really!
  4. razor7

    razor7 Member

    Hi, looking into sys.log, i have seen this suspicious lines...
    Last edited: Sep 7, 2012
  5. falko

    falko Super Moderator ISPConfig Developer

  6. razor7

    razor7 Member

  7. razor7

    razor7 Member

    Well, erased mail.log and restarted, and logging started again, here is the log, it seems that can not connect on port 25, maybe my ISP is blocking it?

    Last edited: Sep 7, 2012
  8. till

    till Super Moderator Staff Member ISPConfig Developer

    Yes, thats a possible reason. If your ISP offers a mail relay server to send outgoing email, then you can set this mailserver under System > Server config > mail.
  9. razor7

    razor7 Member

    Hi, I will call mi ISP, because I have used ISPConfig in the past with no problems. Meanwhile, is there any configuration to use postfix on alternate ports?

    Thanks a lot!
  10. razor7

    razor7 Member

    Well, my ISP Arnet is blocking port 25, they confirmed it. Is there any config that I may change to get POSTFIX use alternate ports (587, 465) instead?

  11. pititis

    pititis Member

    edit master.cf and change:

    smtp      inet  n       -       -       -       -       smtpd
    #submission inet n       -       -       -       -       smtpd
    for this:

    #smtp      inet  n       -       -       -       -       smtpd
    submission inet n       -       -       -       -       smtpd
    and restart postfix

    /etc/init.d/postfix restart
  12. razor7

    razor7 Member

    Well, changed as suggested, but stills tryes to send through port 25.

    Last edited: Sep 8, 2012
  13. ressel

    ressel Member


    Try settings this smtp server as relay:
  14. razor7

    razor7 Member

    Yes. using arnet as relay works ok.

    It is possible to use google apps account for relay?

    Thanks in advise!
  15. ressel

    ressel Member

Share This Page