ubuntu-11.10, saslauthd sasl plain authentication failed no mechanism available

Discussion in 'Installation/Configuration' started by Christovampaynes, Feb 28, 2012.

  1. Christovampaynes

    Christovampaynes New Member

    I changed the server and almost everything is working, I can send and receive mail through the webmail in outlook I just can not send and receive email, this message appears in the logs .. "Feb 27 12:34:36 server postfix / smtpd [25749]: warning: unknown [177.xx.xxx.xxx]: SASL LOGIN authentication failed: no mechanism available" I followed the steps here "http://www.howtoforge.com/ubuntu-11.10-saslauthd-sasl-plain-authentication-failed-no-mechanism-available" however to no avail .. Can someone help me?


    I removed the packages and, "libsasl2-2 libsasl2-dev libsasl2-modules libsasl2-modules-sql", then installed with dpkg.


    root@server:/opt/sasl# ls -la
    total 592
    drwxr-xr-x 2 root root 4096 2012-02-27 13:58 .
    drwxr-xr-x 6 root root 4096 2012-02-20 16:50 ..
    -rw-r--r-- 1 root root 73224 2011-01-07 12:05 libsasl2-2_2.1.23.dfsg1-5ubuntu3_amd64.deb
    -rw-r--r-- 1 root root 253608 2011-01-07 12:05 libsasl2-dev_2.1.23.dfsg1-5ubuntu3_amd64.deb
    -rw-r--r-- 1 root root 116342 2011-01-07 12:05 libsasl2-modules_2.1.23.dfsg1-5ubuntu3_amd64.deb
    -rw-r--r-- 1 root root 27508 2011-01-07 12:05 libsasl2-modules-sql_2.1.23.dfsg1-5ubuntu3_amd64.deb
    -rw-r--r-- 1 root root 121916 2011-01-07 12:05 sasl2-bin_2.1.23.dfsg1-5ubuntu3_amd64.deb


    root@server:/opt/sasl# dpkg -i *.deb
    dpkg: aviso: a fazer downgrade a libsasl2-2 de 2.1.24~rc1.dfsg1+cvs2011-05-23-4ubuntu2 para 2.1.23.dfsg1-5ubuntu3.
    dpkg: erro processando libsasl2-2_2.1.23.dfsg1-5ubuntu3_amd64.deb (--install):
    libsasl2-2:amd64 2.1.23.dfsg1-5ubuntu3 (Multi-Arch: no) is not co-installable with libsasl2-2:i386 2.1.24~rc1.dfsg1+cvs2011-05-23-4ubuntu2 (Multi-Arch: same) which is currently installed
    dpkg: aviso: a fazer downgrade a libsasl2-dev de 2.1.24~rc1.dfsg1+cvs2011-05-23-4ubuntu2 para 2.1.23.dfsg1-5ubuntu3.
    (Lendo banco de dados ... 80792 ficheiros e directórios actualmente instalados.)
    Preparando para substituir libsasl2-dev 2.1.24~rc1.dfsg1+cvs2011-05-23-4ubuntu2 (usando libsasl2-dev_2.1.23.dfsg1-5ubuntu3_amd64.deb) ...
    Desempacotando substituto libsasl2-dev ...
    dpkg: aviso: a fazer downgrade a libsasl2-modules de 2.1.24~rc1.dfsg1+cvs2011-05-23-4ubuntu2 para 2.1.23.dfsg1-5ubuntu3.
    dpkg: erro processando libsasl2-modules_2.1.23.dfsg1-5ubuntu3_amd64.deb (--install):
    libsasl2-modules:amd64 2.1.23.dfsg1-5ubuntu3 (Multi-Arch: no) is not co-installable with libsasl2-modules:i386 2.1.24~rc1.dfsg1+cvs2011-05-23-4ubuntu2 (Multi-Arch: same) which is currently installed
    dpkg: aviso: a fazer downgrade a libsasl2-modules-sql de 2.1.24~rc1.dfsg1+cvs2011-05-23-4ubuntu2 para 2.1.23.dfsg1-5ubuntu3.
    Preparando para substituir libsasl2-modules-sql 2.1.24~rc1.dfsg1+cvs2011-05-23-4ubuntu2 (usando libsasl2-modules-sql_2.1.23.dfsg1-5ubuntu3_amd64.deb) ...
    Desempacotando substituto libsasl2-modules-sql ...
    Preparando para substituir sasl2-bin 2.1.23.dfsg1-5ubuntu3 (usando sasl2-bin_2.1.23.dfsg1-5ubuntu3_amd64.deb) ...
    * Stopping SASL Authentication Daemon saslauthd [ OK ]
    Desempacotando substituto sasl2-bin ...
    dpkg: problemas de dependência impedem a configuração de libsasl2-dev:
    libsasl2-dev depende de libsasl2-modules (= 2.1.23.dfsg1-5ubuntu3); porém:
    Versão de libsasl2-modules no sistema é 2.1.24~rc1.dfsg1+cvs2011-05-23-4ubuntu2.
    dpkg: erro processando libsasl2-dev (--install):
    problemas de dependência - deixando desconfigurado
    dpkg: problemas de dependência impedem a configuração de libsasl2-modules-sql:
    libsasl2-modules-sql depende de libsasl2-modules (= 2.1.23.dfsg1-5ubuntu3); porém:
    Versão de libsasl2-modules no sistema é 2.1.24~rc1.dfsg1+cvs2011-05-23-4ubuntu2.
    dpkg: erro processando libsasl2-modules-sql (--install):
    problemas de dependência - deixando desconfigurado
    Configurando sasl2-bin (2.1.23.dfsg1-5ubuntu3) ...
    update-rc.d: warning: saslauthd stop runlevel arguments (0 1 6) do not match LSB Default-Stop values (1)
    * Starting SASL Authentication Daemon saslauthd [ OK ]
    Processando gatilhos para man-db ...
    Processando gatilhos para ureadahead ...
    Erros foram encontrados durante o processamento de:
    libsasl2-2_2.1.23.dfsg1-5ubuntu3_amd64.deb
    libsasl2-modules_2.1.23.dfsg1-5ubuntu3_amd64.deb
    libsasl2-dev
    libsasl2-modules-sql
     
  2. falko

    falko Super Moderator ISPConfig Developer

    Is this a 32- or a 64-bit system? What's the output of
    Code:
    uname -a
    ?
     
  3. Christovampaynes

    Christovampaynes New Member

    Hello Falko, I ended up doing a downgrade to "ubuntu-11.04".
    follows the output of the command, you can tell me what could be?

    uname -a:
    Linux domain.tld 3.0.0-12-server #20-Ubuntu SMP Mon Apr 11 03:49:04 UTC 2011 x86_64 x86_64 x86_64 GNU/Linux
     
  4. falko

    falko Super Moderator ISPConfig Developer

    Not sure, but according to ...
    Code:
    libsasl2-2:amd64 2.1.23.dfsg1-5ubuntu3 (Multi-Arch: no) is not co-installable with libsasl2-2:i386 2.1.24~rc1.dfsg1+cvs2011-05-23-4ubuntu2 (Multi-Arch: same) which is currently installed
    ... you had the i386 version installed already (not sure how...).
     
  5. Christovampaynes

    Christovampaynes New Member


    strange .. however now I downgrade to Ubuntu-11.04, everything was working and stopped! the logs show it to me "SASL LOGIN authentication failed: generic failure"

    restart:

    /etc/init.d/courier-authdaemon restart
    /etc/init.d/courier-imap restart
    /etc/init.d/courier-imap-ssl restart
    /etc/init.d/courier-pop restart
    /etc/init.d/courier-pop-ssl restart


    I need to reboot the server when this problem. logs shows "conecction refused".


    Mar 5 11:59:20 server pop3d: authentication error: Connection refused
    Mar 5 11:59:25 server pop3d: Connection, ip=[::ffff:177.xx.xx.xxx]
    Mar 5 11:59:25 server pop3d: authdaemon: s_connect() failed: Connection refused
    Mar 5 11:59:25 server pop3d: [Hint: perhaps authdaemond is not running?]
    Mar 5 11:59:25 server pop3d: LOGIN FAILED, user=[email protected], ip=[::ffff:xx.xx.xx.xxx]
    Mar 5 11:59:25 server pop3d: authentication error: Connection refused



    Someone has gone through this?
     
    Last edited: Mar 5, 2012
  6. falko

    falko Super Moderator ISPConfig Developer

    Is courier-authdaemon running?
     
  7. Christovampaynes

    Christovampaynes New Member

    he is falling, it may be the number of connections? is to increase?
     
  8. falko

    falko Super Moderator ISPConfig Developer

    Do you get any errors when you restart courier-authdaemon?
     
  9. Christovampaynes

    Christovampaynes New Member



    no, no errors!!! there comes my doubts that the number of connections!

    Mar 8 09:24:41 server pop3d-ssl: Maximum connection limit reached for ::ffff:167.42.xxx.xx
    Mar 8 09:31:18 server pop3d-ssl: Maximum connection limit reached for ::ffff:167.42.xxx.xxx
     
    Last edited: Mar 8, 2012
  10. Christovampaynes

    Christovampaynes New Member

    I decided to think!

    I had a look at the pop3d set up and changed
    root directory\etc\courier\pop3d
    ##NAME: MAXPERIP:4
    #
    # Maximum number of connections to accept from the same IP address

    MAXDAEMONS=80
    MAXPERIP=116
    -----------------------------------------------
    My doubt is:
    I performed a backup through phpmyadmin, is there a command to create the directories ispconfig3 automatic? (Bind, virtual hosts, users of e-mails) I tried to run update.php but did not work!

    thanks!
     
  11. till

    till Super Moderator Staff Member ISPConfig Developer

    You can use the dns resync tol in ispconfig for bind. For websites and mail accounts there is no tool available, you might have to change a setting in each website and mailbox and save the changes to recreate them if you dont have a backup of the directories.
     
  12. Christovampaynes

    Christovampaynes New Member

    Hello Till,
    Thanks for the info.
     

Share This Page