ubuntu 11.04 cluster

Discussion in 'Installation/Configuration' started by -crisstm-, May 30, 2011.

  1. -crisstm-

    -crisstm- Banned

    Hi all!

    I made a cluster with ubuntu 11.04. i follow instructions from:
    i don't use glusterfs, i choose unison for sincronize the files, and working fast and reliable all services.

    Everithing is working well, exception when one server goes down(master or slave). When i tried to open web site, sometimes open quickly sometimes i must wait about 30 second, sometimes doesn't open. Why ?
    I setup ns1 and ns2, the web site is pointed both Ip's in DNS settings, the slave server is mirror of master server, is propagate from a long time ago...:(
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Any errors in the apache error.log file or syslog?
  3. -crisstm-

    -crisstm- Banned


    i attached print screen with errors.log
    from master and slave too.

    Attached Files:

  4. -crisstm-

    -crisstm- Banned

    nobody can help me?
  5. -crisstm-

    -crisstm- Banned

    i try again. helloooo?
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    This is a forum, so there is no guarantee that someone answers a question or that someone knows the answer to your question.

    Regarding the logs, they look ok so far. Maybe your browser tries to load content from the other server as well and then times out. Which load balancer do you use to switch from one server to the other, or do you use round robin dns?
  7. -crisstm-

    -crisstm- Banned

    Thamk you Till!

    Yes i think i use round robin because in ISPConfig3 panel i set at dns A section, ns2 and ns3 dns server point to each domain.
    Why? Isn't good?
    So how can i set correct load balance in ISPConfig3 between 2 or more dns server?
    As i know bind make load balance, so i think is necessary to point to A the both ns servers. And i give low TTL , my value is 100 seconds.
    I waiting a suggestion.

Share This Page