Ubuntu 11.04 Apache MPM Worker instead of PreFork

Discussion in 'Installation/Configuration' started by DantePasquale, Aug 19, 2011.

  1. DantePasquale

    DantePasquale Member HowtoForge Supporter

    Hi,

    This isn't an ISPConfig question per se, but in order to help out a customer of mine, I need to test with Apache using MPM worker instead of prefork, which is what is installed with Ubuntu 11.04. Not sure how to change this, but don't I just load a different module than prefork?

    Code:
    /usr/sbin/apache2 -M
    [Fri Aug 19 13:39:16 2011] [warn] The Alias directive in /etc/apache2/sql-ledger-httpd.conf at line 32 will probably never match because it overlaps an earlier Alias.
    [Fri Aug 19 13:39:16 2011] [warn] NameVirtualHost XXX.XXX.XX5:80 has no VirtualHosts
    [Fri Aug 19 13:39:16 2011] [warn] NameVirtualHost XXX.XXX.XX5:443 has no VirtualHosts
    [Fri Aug 19 13:39:16 2011] [warn] NameVirtualHost XXX.XXX.XX7:80 has no VirtualHosts
    [Fri Aug 19 13:39:16 2011] [warn] NameVirtualHost XXX.XXX.XX7:443 has no VirtualHosts
    [Fri Aug 19 13:39:16 2011] [warn] NameVirtualHost XXX.XXX.XX6:80 has no VirtualHosts
    [Fri Aug 19 13:39:16 2011] [warn] NameVirtualHost XXX.XXX.XX6:443 has no VirtualHosts
    [Fri Aug 19 13:39:16 2011] [warn] NameVirtualHost XXX.XXX.XX2:80 has no VirtualHosts
    [Fri Aug 19 13:39:16 2011] [warn] NameVirtualHost XXX.XXX.XX2:443 has no VirtualHosts
    [Fri Aug 19 13:39:16 2011] [warn] NameVirtualHost XXX.XXX.XX9:80 has no VirtualHosts
    [Fri Aug 19 13:39:16 2011] [warn] NameVirtualHost XXX.XXX.XX9:443 has no VirtualHosts
    [Fri Aug 19 13:39:16 2011] [warn] NameVirtualHost XXX.XXX.XX8:80 has no VirtualHosts
    [Fri Aug 19 13:39:16 2011] [warn] NameVirtualHost XXX.XXX.XX8:443 has no VirtualHosts
    Loaded Modules:
     core_module (static)
     log_config_module (static)
     logio_module (static)
     mpm_prefork_module (static)
     http_module (static)
     so_module (static)
     actions_module (shared)
     alias_module (shared)
     auth_basic_module (shared)
     authn_file_module (shared)
     authz_default_module (shared)
     authz_groupfile_module (shared)
     authz_host_module (shared)
     authz_user_module (shared)
     autoindex_module (shared)
     cgi_module (shared)
     deflate_module (shared)
     dir_module (shared)
     env_module (shared)
     fcgid_module (shared)
     include_module (shared)
     mime_module (shared)
     negotiation_module (shared)
     php5_module (shared)
     reqtimeout_module (shared)
     rewrite_module (shared)
     setenvif_module (shared)
     ssl_module (shared)
     status_module (shared)
     suexec_module (shared)
     suphp_module (shared)
    Syntax OK
    Thanks!
     
  2. falko

    falko Super Moderator ISPConfig Developer

    No, you must install another Apache2 package: apache2-mpm-worker

    This will probably remove apache2-mpm-prefork which might cause problems if you use mod_php.
     

Share This Page