Ubuntu 10.04 with suEXEC - Joomla upload errors

Discussion in 'HOWTO-Related Questions' started by jumba, Jun 7, 2010.

  1. jumba

    jumba New Member

    I solved a part of problem by disabling PHP globally.
    But there are still some problems. I can install some components from within Joomla but I can't install templates (which are under 1 Mb) nor upload archives from within components.
    When I try to upload a template (which works perfectly on other servers), the tar.gz file is copied to /web/tmp (Joomla's temp directory) and it is extracted in a subdirectory. However, it is not extracted properly. It creates some files with odd names ( like this one: ]->removeChild($child); which have 0 bytes) that shouldn't be there. These extracted files are not copied from the /tmp directory to the destination directory. Their permissions are OK (644 for files and 755 for directories, and the owner is the right one, like web1 from group client1).
    If I try to upload some zip files (under 1Mb) from within other components, some files from the zip are uploaded but have 0 bytes and others are not uploaded at all.

    All permissions are OK. Joomla says all directories are writable.

    Web Server to PHP interface: cgi-fcgi
    max_execution_time 60
    post_max_size 16M
    upload_max_filesize 20M
     
  2. falko

    falko Super Moderator ISPConfig Developer

    Any errors in Apache's error log?
     
  3. jumba

    jumba New Member

    No recent errors in Apache's log.
    I thought this had to do with some php.ini settings so I copied a php.ini from another ISPConfig 3 installation (Ubuntu 8.04) that is working without problems, restarted Apache and made sure that the new php.ini was loaded (the new php.ini had Show Warnings On). Unfortunately, the errors are still there.
    When I try to upload any template (I tried with several that work perfectly on the other server) I get a blank page or errors like "Unable to write entry" or "Could not find an XML setup file in the package".
    I googled those errors but no luck. Joomla's FTP layer is turned off, php safe mode is off, I tried unarchiving and archiving those files again but it made no difference. It happens with .zip and .tat.gz. Using a Joomla 1.5.18 fresh install with Legacy mode turned Off.
     
    Last edited: Jun 18, 2010
  4. falko

    falko Super Moderator ISPConfig Developer

    I still think this could be some kind of permissions problem, but I can't say where to start checking... :(
     

Share This Page