Ubuntu 10.04 - client denied by server configuration

Discussion in 'Installation/Configuration' started by muucest, May 17, 2010.

  1. muucest

    muucest New Member

    I just installed Ubuntu 10.04 by the perfect server tutorial but the system cannot access virtual host directories made by ISPConfig.

    The error I see in apache2 error.log is "client denied by server configuration" - it seems to go for the virtual host directories and also /var/www/clients/, /var/www/php-fcgi-scripts/ - for me (trying to access it from outside) and even the server itself (127.0.0.1).

    I can access files directly in /var/www/ though (by typing ip/filename to browser).

    --

    OK, I figured out that by changing first "Deny all" to "Allow all" in /etc/apache2/sites-enabled/sitename.com.vhost it starts working:

    <Directory /var/www/sitename.com>
    AllowOverride None
    Order Deny,Allow
    Allow from all
    </Directory>

    - is this an OK solution and can I make it so I wouldn't have to change it manually every time I add a vhost?
     
    Last edited: May 17, 2010
  2. rajchd

    rajchd New Member

    Thanks

    Thanks for posting the solution, it helped me.
     
  3. till

    till Super Moderator

    Thats not the solution as you opened up your system for hackers by opening up private directories which contain password files etc. The source of your problem is that you uploaded the files into the wrong directory. All php and html files have to be uploaded to /var/www/sitename.com/web/ and not /var/www/sitename.com/
     
  4. maileh

    maileh New Member

    upload files

    Till
    With what you said above, i have transfer all my files to the /var/www/domain/web but still got the same error. Maybe i need to set it somewhere ...please can you shed some light on it.
    Regards
    Maile
     

Share This Page