Ubunto 8.05 upgrade to 8.10 + ebox

Discussion in 'Server Operation' started by planet_fox, Nov 13, 2008.

  1. planet_fox

    planet_fox New Member

    I have do yesterdays a dist upgrade on my server an have some Problems with perl and slapd. On the System run ebox
    and the upgrade stop while I have this message from system

    Code:
    Fehler traten auf beim Bearbeiten von:
     libapache2-mod-perl2
     perl
     perl-modules
    Code:
    Probieren Sie »apt-get -f install«, um diese zu korrigieren.
    Die folgenden Pakete haben nicht erfüllte Abhängigkeiten:
      libapache2-mod-perl2: Hängt ab: perlapi-5.10.0
                            Hängt ab: libperl5.10 (>= 5.10.0) ist aber nicht installiert
                            Empfiehlt: libbsd-resource-perl ist aber nicht installiert
                            Empfiehlt: libapache2-reload-perl ist aber nicht installiert
      perl: Hängt ab: perl-base (= 5.10.0-11.1ubuntu2) aber 5.8.8-12 ist installiert
      slapd: Hängt ab: libldap-2.4-2 (= 2.4.9-0ubuntu0.8.04.1) aber 2.4.11-0ubuntu6 ist installiert
             Empfiehlt: apparmor (>= 2.1+1075-0ubuntu6) ist aber nicht installiert
    E: Nicht erfüllte Abhängigkeiten. Versuchen Sie, -f zu benutzen.
    When i try apt-get -f install comes this error

    Code:
    /tmp/slapd.config.266141: line 944: local: can only be used in a function
    slapd konnte nicht vorkonfiguriert werden, Exit-Status 1
    Wähle vormals abgewähltes Paket libperl5.10.
    (Lese Datenbank ... 91994 Dateien und Verzeichnisse sind derzeit installiert.)
    Entpacke libperl5.10 (aus .../libperl5.10_5.10.0-11.1ubuntu2_i386.deb) ...
    Vorbereiten zum Ersetzen von slapd 2.4.9-0ubuntu0.8.04.1 (durch .../slapd_2.4.11-0ubuntu6_i386.deb) ...
    Stopping OpenLDAP: slapd.
    /var/lib/dpkg/tmp.ci/config: line 944: local: can only be used in a function
    dpkg: Fehler beim Bearbeiten von /var/cache/apt/archives/slapd_2.4.11-0ubuntu6_i386.deb (--unpack):
     Unterprozess pre-installation script gab den Fehlerwert 1 zurück
      Backing up /etc/ldap/slapd.conf in /var/backups/slapd-2.4.11-0ubuntu6... done.
    Starting OpenLDAP: slapd.
    Fehler traten auf beim Bearbeiten von:
     /var/cache/apt/archives/slapd_2.4.11-0ubuntu6_i386.deb
    E: Sub-process /usr/bin/dpkg returned an error code (1)
     
  2. falko

    falko Super Moderator ISPConfig Developer

    What's in /etc/apt/sources.list?
     
  3. planet_fox

    planet_fox New Member

    You to late, till i haves help me in german forum, i have no sulution found. I have yesterdays Testing new fresh Install of Ubunto 8.10 and ebox . Many Problems have ebox with some Packages and than I have Ubunto 8.05 Install and wait for a stable version of ebox for ubunto 8.10. When Ebox have a stable version i do a image before I upgrade my system.
     

Share This Page