two versions PHP with Ubuntu 12.04

Discussion in 'Installation/Configuration' started by creatiel, Apr 9, 2014.

  1. creatiel

    creatiel New Member

    Hi all,

    I added PHP 5.2.17 and I added parameters (path fcgi, ini) in the panel ISPConfig.

    Now, I can select this PHP version and PhpInfo displays correctly:
    :) "PHP Version 5.2.17"

    :mad: BUT Mysql does not work!
    (by default Mysql is OK with other Php 5.3.10)

    Please, could you help me ...

    Gilles
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Did you had any compile errors? Did you follow one of the multi php version tutorials from howtoforge?
     
  3. creatiel

    creatiel New Member

    thank till,

    Here, I don't find a special howto compilation of php 5.2.17.

    First, I did read this tuto:
    http://zgadzaj.com/how-to-install-php-53-and-52-together-on-ubuntu-1204
    because it describes how to install php 5.2.17 and make ‚Äč‚Äčeasy fastcgi.

    Then I did read your tuto:
    http://www.howtoforge.com/how-to-use-multiple-php-versions...
    about rights parameters for ISPConfig.

    Before compliation, I added all required libraries and some bug fixes, and there were no errors during compilation.
    and zero error during make - make install.

    After, PhpInfo version is good ... but Mysql unless !!

    Gilles
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

  5. creatiel

    creatiel New Member

    Ok, I'm trying this howto..

    but, I can't compile php 5.2.17 with options:

    Code:
    ./configure --prefix=/opt/phpfcgi-5.2.17 --with-pdo-pgsql --with-zlib-dir --with-freetype-dir --enable-mbstring --with-libxml-dir=/usr --enable-soap --enable-calendar --with-curl --with-mcrypt --with-zlib --with-gd --with-pgsql --disable-rpath --enable-inline-optimization --with-bz2 --with-zlib --enable-sockets --enable-sysvsem --enable-sysvshm --enable-pcntl --enable-mbregex --with-mhash --enable-zip --with-mysql --with-pdo-mysql --with-mysqli --with-jpeg-dir=/usr --with-png-dir=/usr --enable-gd-native-ttf --with-openssl --with-libdir=/lib/x86_64-linux-gnu --enable-ftp --with-imap --with-imap-ssl --with-kerberos --with-gettext --enable-cgi
    there is an error during 'make':



    Code:
    gd.c:(.text+0x3d6): undefined reference to `gdImageWBMPCtx'
    ext/gd/.libs/gd.o: In function `php_free_ps_enc':
    gd.c:(.text+0xbb4): undefined reference to `T1_DeleteEncoding'
    ext/spl/.libs/spl_iterators.o: In function `zim_spl_RegexIterator_accept':
    
    /usr/local/src/php5-build/php-5.2.17/ext/spl/spl_iterators.c:1397: undefined reference to `pcre_exec'
    collect2: ld returned 1 exit status
    make: *** [sapi/cgi/php-cgi] Error 1
    What do I do ?

    Thank / Gilles
     
  6. creatiel

    creatiel New Member

    Ok, I did remake all ... that is right !!
     
    Last edited: Apr 9, 2014

Share This Page